aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended/at/at_%.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at_%.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
new file mode 100644
index 0000000000..3a22fe3bda
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
@@ -0,0 +1,16 @@
+inherit systemd
+
+# look for files in the layer first
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://atd.service"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "atd.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
+}
+