aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index 0e08358b29..89079dcae1 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -7,4 +7,11 @@ inherit systemd
SRC_URI += "file://lighttpd.service"
SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "lighttpd.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
+}
+