aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core/systemd/systemd-speed-hacks.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/recipes-core/systemd/systemd-speed-hacks.bb')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-speed-hacks.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd-speed-hacks.bb b/meta-systemd/recipes-core/systemd/systemd-speed-hacks.bb
new file mode 100644
index 0000000000..8cfcc4c378
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd-speed-hacks.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Collection of hacks to speed up systemd boot"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r1"
+
+inherit allarch
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN} () {
+#!/bin/sh
+# I can run offline
+rm -f $D/lib/systemd/system/sysinit.target.wants/systemd-tmpfiles-setup.service
+
+rm -f $D/lib/systemd/system/sysinit.target.wants/sys-fs-fuse-connections.mount
+rm -f $D/lib/systemd/system/sysinit.target.wants/sys-kernel-debug.mount
+}