aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch19
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch39
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch31
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb4
4 files changed, 61 insertions, 32 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch b/meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch
new file mode 100644
index 0000000000..35f1467c54
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch
@@ -0,0 +1,19 @@
+on uclibc secure_getenv is not available
+therefore default to using getenv instead
+
+Singed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: git/src/shared/missing.h
+===================================================================
+--- git.orig/src/shared/missing.h 2012-09-22 18:46:44.141282145 -0700
++++ git/src/shared/missing.h 2012-09-22 18:48:44.081276570 -0700
+@@ -233,6 +233,8 @@
+ #ifndef HAVE_SECURE_GETENV
+ # ifdef HAVE___SECURE_GETENV
+ # define secure_getenv __secure_getenv
++# elif defined __UCLIBC__
++# define secure_getenv getenv
+ # else
+ # error neither secure_getenv nor __secure_getenv are available
+ # endif
diff --git a/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch b/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch
index ea8b3ffb19..449c27f88c 100644
--- a/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch
+++ b/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch
@@ -1,29 +1,26 @@
---- systemd-pam-185/src/nspawn/nspawn.c.orig 2012-06-21 05:31:24.000000000 -0400
-+++ systemd-pam-185/src/nspawn/nspawn.c 2012-06-21 05:29:50.000000000 -0400
-@@ -61,6 +61,8 @@
- #include "path-util.h"
- #include "loopback-setup.h"
+Index: git/src/nspawn/nspawn.c
+===================================================================
+--- git.orig/src/nspawn/nspawn.c 2012-09-22 17:57:05.000000000 -0700
++++ git/src/nspawn/nspawn.c 2012-09-22 18:01:41.541405768 -0700
+@@ -63,6 +63,8 @@
+ LINK_GUEST
+ } LinkJournal;
+#include "config.h"
+
static char *arg_directory = NULL;
static char *arg_user = NULL;
static char **arg_controllers = NULL;
-@@ -1315,9 +1317,14 @@
-
- a[0] = (char*) "/sbin/init";
- execve(a[0], a, (char**) envp);
-- } else if (argc > optind)
-- execvpe(argv[optind], argv + optind, (char**) envp);
-- else {
-+ } else if (argc > optind) {
+@@ -1373,7 +1375,12 @@
+ a[0] = (char*) "/sbin/init";
+ execve(a[0], a, (char**) envp);
+ } else if (argc > optind)
+#ifdef HAVE_EXECVPE
-+ execvpe(argv[optind], argv + optind, (char**) envp);
+ execvpe(argv[optind], argv + optind, (char**) envp);
+#else
-+ environ = (char **)envp;
-+ execvp(argv[optind], argv + optind);
-+#endif /* HAVE_EXECVPE */
-+ } else {
- chdir(home ? home : "/root");
- execle("/bin/bash", "-bash", NULL, (char**) envp);
- }
++ environ = (char **)envp;
++ execvp(argv[optind], argv + optind);
++#endif /* HAVE_EXECVPE */
+ else {
+ chdir(home ? home : "/root");
+ execle("/bin/bash", "-bash", NULL, (char**) envp);
diff --git a/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
index 2167216844..4c471b673b 100644
--- a/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
+++ b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
@@ -11,17 +11,19 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Index: git/Makefile.am
===================================================================
---- git.orig/Makefile.am 2012-07-22 16:20:38.424405916 -0700
-+++ git/Makefile.am 2012-07-22 16:23:21.232406621 -0700
-@@ -61,23 +61,23 @@
+--- git.orig/Makefile.am 2012-09-22 11:07:58.811981199 -0700
++++ git/Makefile.am 2012-09-22 11:09:11.267983956 -0700
+@@ -64,25 +64,25 @@
# Our own, non-special dirs
pkgsysconfdir=$(sysconfdir)/systemd
-userunitdir=$(prefix)/lib/systemd/user
+-userpresetdir=$(prefix)/lib/systemd/user-preset
-tmpfilesdir=$(prefix)/lib/tmpfiles.d
-sysctldir=$(prefix)/lib/sysctl.d
-usergeneratordir=$(prefix)/lib/systemd/user-generators
+userunitdir=$(prefix)/$(rootlibdir)/systemd/user
++userpresetdir=$(prefix)/$(rootlibdir)/systemd/user-preset
+tmpfilesdir=$(prefix)/$(rootlibdir)/tmpfiles.d
+sysctldir=$(prefix)/$(rootlibdir)/sysctl.d
+usergeneratordir=$(prefix)/$(rootlibdir)/systemd/user-generators
@@ -30,8 +32,10 @@ Index: git/Makefile.am
systemshutdowndir=$(rootlibexecdir)/system-shutdown
systemsleepdir=$(rootlibexecdir)/system-sleep
-systemunitdir=$(rootprefix)/lib/systemd/system
+-systempresetdir=$(rootprefix)/lib/systemd/system-preset
-udevlibexecdir=$(rootprefix)/lib/udev
+systemunitdir=$(rootprefix)/$(rootlibdir)/systemd/system
++systempresetdir=$(rootprefix)/$(rootlibdir)/systemd/system-preset
+udevlibexecdir=$(rootprefix)/$(rootlibdir)/udev
udevhomedir = $(udevlibexecdir)
udevrulesdir = $(udevlibexecdir)/rules.d
@@ -42,9 +46,9 @@ Index: git/Makefile.am
-rootlibexecdir=$(rootprefix)/lib/systemd
+rootlibexecdir=$(rootprefix)/$(rootlibdir)/systemd
- CLEANFILES =
+ CLEANFILES = $(BUILT_SOURCES)
EXTRA_DIST =
-@@ -126,7 +126,7 @@
+@@ -132,7 +132,7 @@
-DSYSTEMD_STDIO_BRIDGE_BINARY_PATH=\"$(bindir)/systemd-stdio-bridge\" \
-DROOTPREFIX=\"$(rootprefix)\" \
-DRUNTIME_DIR=\"/run\" \
@@ -53,7 +57,7 @@ Index: git/Makefile.am
-DSYSTEMD_CRYPTSETUP_PATH=\"$(rootlibexecdir)/systemd-cryptsetup\" \
-DSYSTEM_GENERATOR_PATH=\"$(systemgeneratordir)\" \
-DUSER_GENERATOR_PATH=\"$(usergeneratordir)\" \
-@@ -2535,7 +2535,7 @@
+@@ -2692,7 +2692,7 @@
binfmt-install-data-hook:
$(MKDIR_P) -m 0755 \
@@ -62,7 +66,16 @@ Index: git/Makefile.am
$(DESTDIR)$(sysconfdir)/binfmt.d \
$(DESTDIR)$(systemunitdir)/sysinit.target.wants
( cd $(DESTDIR)$(systemunitdir)/sysinit.target.wants && \
-@@ -3165,7 +3165,7 @@
+@@ -3107,7 +3107,7 @@
+
+ timedated-install-data-hook:
+ $(MKDIR_P) -m 0755 \
+- $(DESTDIR)$(prefix)/lib/systemd/ntp-units.d \
++ $(DESTDIR)$(prefix)/$(rootlibdir)/systemd/ntp-units.d \
+ $(DESTDIR)$(sysconfdir)/systemd/ntp-units.d
+ ( cd $(DESTDIR)$(systemunitdir) && \
+ rm -f dbus-org.freedesktop.timedate1.service && \
+@@ -3337,7 +3337,7 @@
logind-install-data-hook:
$(MKDIR_P) -m 0755 \
$(DESTDIR)$(systemunitdir)/multi-user.target.wants \
@@ -71,7 +84,7 @@ Index: git/Makefile.am
( cd $(DESTDIR)$(systemunitdir) && \
rm -f dbus-org.freedesktop.login1.service && \
$(LN_S) systemd-logind.service dbus-org.freedesktop.login1.service)
-@@ -3284,7 +3284,7 @@
+@@ -3494,7 +3494,7 @@
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
-e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' \
@@ -80,7 +93,7 @@ Index: git/Makefile.am
-e 's,@prefix\@,$(prefix),g' \
-e 's,@exec_prefix\@,$(exec_prefix),g' \
-e 's,@libdir\@,$(libdir),g' \
-@@ -3407,9 +3407,9 @@
+@@ -3619,9 +3619,9 @@
$(MKDIR_P) -m 0755 \
$(DESTDIR)$(tmpfilesdir) \
$(DESTDIR)$(sysconfdir)/tmpfiles.d \
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index 337424eec8..512f5d477b 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -23,8 +23,7 @@ PR = "r7"
inherit useradd pkgconfig autotools perlnative
-SRCREV = "38a60d7112d33ffd596b23e8df53d75a7c09e71b"
-
+SRCREV = "a3eb665e0c12df35e807611582e7332ebed325b1"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
file://use-rootlibdir.patch \
file://gtk-doc.make \
@@ -40,6 +39,7 @@ UCLIBCPATCHES_libc-uclibc = "file://systemd-pam-configure-check-uclibc.patch \
file://systemd-pam-fix-getty-unit.patch \
file://systemd-pam-fix-mkostemp.patch \
file://systemd-pam-fix-msformat.patch \
+ file://optional_secure_getenv.patch \
"
LDFLAGS_libc-uclibc_append = " -lrt"