aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
index 035602934b..573cd6fb00 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
@@ -112,7 +112,7 @@ INITSCRIPT_NAME = "apache2"
INITSCRIPT_PARAMS = "defaults 91 20"
LEAD_SONAME = "libapr-1.so.0"
-PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
+PACKAGES = "${PN}-scripts ${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
CONFFILES_${PN} = "${sysconfdir}/${BPN}/httpd.conf \
${sysconfdir}/${BPN}/magic \
@@ -129,11 +129,16 @@ FILES_${PN}-dev = "${datadir}/${BPN}/build \
${libdir}/apr*.exp \
${includedir}/${BPN} \
${libdir}/*.la \
- ${libdir}/*.a"
+ ${libdir}/*.a \
+ ${bindir}/apxs \
+ "
+
# manual to manual
FILES_${PN}-doc += " ${datadir}/${BPN}/manual"
+FILES_${PN}-scripts += "${bindir}/dbmmanage"
+
#
# override this too - here is the default, less datadir
#
@@ -150,3 +155,4 @@ FILES_${PN} += "${libdir}/lib*.so ${libdir}/pkgconfig/*"
FILES_${PN}-dbg += "${libdir}/${BPN}/modules/.debug"
RDEPENDS_${PN} += "openssl libgcc"
+RDEPENDS_${PN}-scripts += "perl ${PN}"