aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
Commit message (Collapse)AuthorAgeFilesLines
* faac: address gcc-6 narrowing errors via an explicit castDerek Straka2016-08-162-2/+50
| | | | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 9b9eb830b60a0564e7f5b00eb12a57e652484227) Signed-off-by: Armin Kuster <akuster808@gmail.com>
* dvd-apps: Fix several QA WARNINGSArmin Kuster2016-08-161-0/+10
| | | | | | | | | | | | | | | | | | | Example: WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbdate contained in package dvbdate requires libucsi.so, but no providers found in RDEPENDS_dvbdate? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbtraffic contained in package dvbtraffic requires libdvbapi.so, but no providers found in RDEPENDS_dvbtraffic? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbscan contained in package dvb-scan requires libdvbapi.so, but no providers found in RDEPENDS_dvb-scan? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/gotox contained in package dvb-apps requires libdvbapi.so, but no providers found in RDEPENDS_dvb-apps? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/femon contained in package dvb-femon requires libdvbapi.so, but no providers found in RDEPENDS_dvb-femon? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbnet contained in package dvbnet requires libdvbapi.so, but no providers found in RDEPENDS_dvbnet? [file-rdeps] and WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbscan contained in package dvb-scan requires libdvbcfg.so, but no providers found in RDEPENDS_dvb-scan? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/gotox contained in package dvb-apps requires libdvbapi.so, but no providers found in RDEPENDS_dvb-apps? [file-rdeps] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 350bd0bee460633592df3d9211b9cc15b4f9cb11) Signed-off-by: Armin Kuster <akuster808@gmail.com>
* fluidsynth: set correct portaudio packageconfig dependencyAndreas Müller2016-05-091-1/+1
| | | | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* sox: dep on ffmpeg, not libavChristopher Larson2016-05-091-1/+1
| | | | | | | | | | The libav recipe no longer exists, in favor of ffmpeg. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* meta-multimedia: use bb.utils.contains() instead of base_contains()Ross Burton2016-05-028-20/+20
| | | | | | | | | base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* README: update maintainers list for krogothArmin Kuster2016-04-121-7/+6
| | | | | Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gst-plugins.inc: inherit gobject-introspectionMartin Jansa2016-04-121-1/+2
| | | | | | | | | | * fixes: gst-plugins-gl-0.10.3: gst-plugins-gl: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] gst-plugins-bad-0.10.23: gst-plugins-bad: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] gst-plugins-good-0.10.31: gst-plugins-good: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] gst-plugins-ugly-0.10.19: gst-plugins-ugly: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gstreamer: fix argument parsing when using Bison 3Stefan Agner2016-04-013-34/+36
| | | | | | | | | | | | Remove the argument fix patch and add a patch which fixes the grammer.y Bison input file. YYLEX_PARAM seems to be no longer supported and has been replaced with %parse-param which has been introduced already in 2003. This fixes a segmentation fault when launching gst-launch-0.10. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libmediaart: fix gobject introspectionAlexander Kanavin2016-03-141-2/+2
| | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* gstreamer-0.10: disable gobject introspectionAlexander Kanavin2016-03-143-1/+4
| | | | | | | Making it work would require significant patching - if you need it, update your stack to gstreamer 1.x Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* python-gst: remove the 0.10 recipeAlexander Kanavin2016-03-142-57/+0
| | | | | | It depends on pygobject 2.x which has been update to 3.x in oe-core Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* media-service-demo: remove the recipeAlexander Kanavin2016-03-141-18/+0
| | | | | | | | It hasn't been updated in years, and depends on pygtk, which is obsolete and incompatible with pygobject 3.x (and so is no longer provided). Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* rygel: fix gobject introspectionAlexander Kanavin2016-03-141-2/+2
| | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* gupnp: fix gobject introspectionAlexander Kanavin2016-03-146-23/+25
| | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* libao: update to 1.2.0Derek Straka2016-03-141-2/+4
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: add libpng PACKAGECONFIG (on by default)Rafaël Carré2016-03-071-2/+2
| | | | | | WARNING: vlc-2.2.2-r0 do_package_qa: QA Issue: vlc rdepends on libpng, but it isn't a build dependency, missing libpng in DEPENDS or PACKAGECONFIG? [build-deps] Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: fix build with ffmpeg 3.0Rafaël Carré2016-03-073-0/+340
| | | | | Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: update to 2.2.2Rafaël Carré2016-03-072-22/+2
| | | | | | | Drop rdp.c patch obsoleted by upstream changes Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: Fix typo introduced in 0f2b3139521570ad494a72399f8a9dae76e69b16Rafaël Carré2016-03-071-1/+1
| | | | | | | | | | | | vlc-2.2.1: vlc: invalid PACKAGECONFIG: {@bb.utils.contains('DISTRO_FEATURES', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: 'x11', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: 'x11 [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: sdl', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: '', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: d)} [invalid-packageconfig] Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode,links"Martin Jansa2016-03-042-2/+2
| | | | | | | | | * Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gst-ffmpeg: blacklist, not compatible with currently used ffmpeg 3Martin Jansa2016-03-041-0/+3
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: make sdl optional (enabled by default)Rafaël Carré2016-02-251-3/+3
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: make x11 DISTRO_FEATURE optional (enabled by default)Rafaël Carré2016-02-251-5/+4
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libmatroska: Explicitly set EXTRA_OEMAKE as requiredMike Crowe2016-02-251-0/+2
| | | | | | | | | This recipe currently relies on EXTRA_OEMAKE having been to set to "-e MAKEFLAGS=" in bitbake.conf to operate. It is necessary to make this explicit so that the default in bitbake.conf can be changed. Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gst-plugins-base: add perl runtime dependency to gst-plugins-base-appsAndre McCurdy2016-02-151-0/+3
| | | | | | | | | | | | | gst-plugins-base-apps contains /usr/bin/gst-visualise-0.10, which is a perl script. Note that the gst-visualise-0.10 script was dropped upstream prior to the first gst-plugins-base 1.0 release: http://cgit.freedesktop.org/gstreamer/gst-plugins-base/commit/?id=227be98c0b65a1616c0d0689db6fa7576bcbe434 Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libebml: Explicitly set EXTRA_OEMAKE as requiredMike Crowe2016-02-151-0/+2
| | | | | | | | | This recipe currently relies on EXTRA_OEMAKE having been to set to "-e MAKEFLAGS=" in bitbake.conf to operate. It is necessary to make this explicit so that the default in bitbake.conf can be changed. Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* rygel: Update to 0.28.2Manuel Bachmann2016-02-151-5/+6
| | | | | | | | | | | | | | | | | Update to latest version. This mainly fixes file uploading, which did not work in previous version (see upstream commit "1d45866a3fd7ca47bdbea60156bd18b994710662" among others). sqlite3 is now required to build whole rygel, as some media-export plugin routines have been centralized ; libunistring also improves collation logic if present. Rygel will not keep running anymore when its "plugins" folder is absent or empty. Thus, to avoid disappointments, we now RRECOMMEND at least the media-export plugin. Signed-off-by: Manuel Bachmann <mbc@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gupnp: Update to 0.20.14Manuel Bachmann2016-02-152-3/+3
| | | | | | | | | | | Update to latest version (required for latest Rygel). As the unique executable provided by "gupnp-dev" cannot work without python, switch from RRECOMMENDS to RDEPENDS for it, and also be more precise in its required modules. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* liboil: import liboil_0.3.17 recipe from oe-coreAndre McCurdy2016-02-015-0/+333
| | | | | | | | | | | | There are no remaining dependencies on liboil in oe-core (in most cases it has been replaced by 'orc'). There is one recipe with a dependency on liboil in meta-multimedia ('schroedinger'). Add the oe-core liboil recipe to meta-multimedia, in preparation for removing it from oe-core. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gst-plugins-base: drop obsolete dependency on liboilAndre McCurdy2016-02-011-1/+1
| | | | | | | | | liboil was replaced by Orc prior to the gst-plugins-base 0.10.30 release: http://cgit.freedesktop.org/gstreamer/gst-plugins-base/commit/?id=8e4314f0fbfa4957f8e84d46824d10178b106fe6 Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpg123: add textrel to INSANE_SKIPAndre McCurdy2016-01-041-0/+4
| | | | | | | | | | | | | The x86 assembler optimisations contains text relocations and there are no upstream plans to fix them: http://sourceforge.net/p/mpg123/bugs/168/ Benchmarking suggests that the SSE assembler is still clearly faster than the generic C code, so leave the assembler optimisations enabled. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* VLC: depend on jpeg rather than libjpeg-turboRafaël Carré2016-01-041-1/+1
| | | | | | The underlying libjpeg implementation doesn't matter Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* VLC: PACKAGECONFIG for new dependency on libvncserverRafaël Carré2016-01-041-0/+1
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpd: add dependency on libupnpMartin Jansa2015-12-181-1/+1
| | | | | | | * it's autodetected from sysroot: WARN: mpd: mpd rdepends on libupnp, but it isn't a build dependency? Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpg123: update 1.21.0 -> 1.22.4Andre McCurdy2015-12-181-2/+2
| | | | | | | | http://mpg123.de/cgi-bin/scm/mpg123/tags/1.22.4/NEWS 1.22.4 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpg123: drop unnecessary dependency on tslibAndre McCurdy2015-12-181-1/+1
| | | | | | | | | The mpg123 sources don't contain any references to tslib or -lts and there are no obvious build issues or QA warnings after the tslib dependency is removed. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpg123: limit ARM_INSTRUCTION_SET = "arm" over-ride to armv4/armv5Andre McCurdy2015-12-181-1/+2
| | | | | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpg123: recipe formatting cleanup, no functional changesAndre McCurdy2015-12-181-20/+22
| | | | | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* VLC: do not use --with-contribRafaël Carré2015-12-181-1/+0
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* VLC: make libdvdread PACKAGECONFIGRafaël Carré2015-12-181-4/+4
| | | | | | | Enable it by default. Make both dvdread and dvdnav also depend on libdvdcss Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* VLC: explicit PACKAGECONFIG for freetypeRafaël Carré2015-12-181-1/+2
| | | | | | Enable it by default Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* VLC: explicit PACKAGECONFIG for fontconfigRafaël Carré2015-12-181-1/+2
| | | | | | Enable it by default Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* VLC: make libnotify a configurable dependencyRafaël Carré2015-12-181-2/+3
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: remove libdc1394 libraw1394 from DEPENDSRafaël Carré2015-12-181-2/+2
| | | | | | | They are only needed if the modules introduced in ea31946 are enabled. Add these modules to default PACKAGECONFIG to keep existing defaults. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dleyna-renderer: Add recipeManuel Bachmann2015-12-181-0/+23
| | | | | | | | | | | | dleyna-renderer is a library for implementing Digital Media (DLNA) Renderers, and also provides a sample implementation of such a renderer. "dleyna-renderer-service" is designed to be started and consumed using D-Bus. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dleyna-server: Add recipeManuel Bachmann2015-12-181-0/+21
| | | | | | | | | | | | dleyna-server is a library for implementing Digital Media (DLNA) Servers, and also provides a sample implementation of such a server. "dleyna-server-service" is designed to be started and consumed using D-Bus. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dleyna-connector-dbus: Add recipeManuel Bachmann2015-12-181-0/+18
| | | | | | | | | | | dleyna-connector-dbus is a D-Bus connector library depending on "dleyna-core", and needed by dLeyna implementations (most notably "dleyna-server" and "dleyna-renderer"). It allows them to discover D-Bus buses, and to be started via D-Bus services files. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dleyna-core: Add recipeManuel Bachmann2015-12-181-0/+18
| | | | | | | | | | | | dleyna-core is a library of utility functions needed by other dLeyna packages (most notably "dleyna-connector-dbus" "dleyna-server" and "dleyna-renderer"). It provides APIs for logging, error, settings, task management and an IPC abstraction API. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: add PACKAGECONFIG for samba, upnp, dvdnav, sftp, vorbis, dc1394, ↵Martin Jansa2015-11-161-1/+11
| | | | | | | | | | | | | | | | | | dv1394, svg, svgdec * hopefully fixes: WARN: vlc: vlc rdepends on libavc1394, but it isn't a build dependency? WARN: vlc: vlc rdepends on libcroco, but it isn't a build dependency? WARN: vlc: vlc rdepends on libcrypto, but it isn't a build dependency? WARN: vlc: vlc rdepends on libdvdnav, but it isn't a build dependency? WARN: vlc: vlc rdepends on librsvg, but it isn't a build dependency? WARN: vlc: vlc rdepends on libssh2, but it isn't a build dependency? WARN: vlc: vlc rdepends on libssl, but it isn't a build dependency? WARN: vlc: vlc rdepends on libupnp, but it isn't a build dependency? WARN: vlc: vlc rdepends on libvorbis, but it isn't a build dependency? WARN: vlc: vlc rdepends on libxml2, but it isn't a build dependency? Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* sox: add PACKAGECONFIG for flac, armwb, amrnbMartin Jansa2015-11-161-0/+3
| | | | | | | | * hopefully fixes: sox-14.4.0: sox rdepends on libflac, but it isn't a build dependency? [build-deps] sox-14.4.0: sox rdepends on opencore-amr, but it isn't a build dependency? [build-deps] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>