aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php/php_5.6.26.bb
Commit message (Collapse)AuthorAgeFilesLines
* php: disable this version by defaultJoe Slater2017-08-281-0/+9
| | | | | | | | | There are many unaddressed CVEs which are fixed in 7.1.7 and later versions. Allow the user to define php_5.6.26 to enable building the recipe. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* php: fix install error for libphp*.sodengke.du@windriver.com2017-05-231-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | Changed in V4: Add the tag: meta-oe 1. Different version php have different libphp*.so, so we need to install its corresponding libphp*.so, for example: php-7.1.0 libphp7.so php-5.6.26 libphp5.so 2. Fix php-5.6.26 compiling errors: ld: TSRM/.libs/TSRM.o: undefined reference to symbol 'pthread_sigmask@@GLIBC_2.2.5' error adding symbols: DSO missing from command line 3. Create a configure script like 70_mod_php5, we name it 70_mod_php7, this file connect the php7 and the apache2, so they work together to let the LAMP works correctly. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* php: remove PNBLACKLISTRobert Yang2017-04-181-2/+0
| | | | | | | | | | | | | | It has been fixed since: commit b5bb61163751d93672bdcdfb24dda21398e42657 Author: dengke.du@windriver.com <dengke.du@windriver.com> Date: Tue Mar 28 04:13:36 2017 -0400 php: fix install failure Also remove it for xdebug since php works now. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: add removal date to PNBLACKLIST messagesMartin Jansa2017-04-051-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | * based on discussion in pndeprecated thread: https://patchwork.openembedded.org/patch/137573/ update the messages to warn possible users that the recipe will be removed before the end of the next development cycle (before Yocto 2.4 is released). * updated with: sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs` * then noticed couple recipes being blacklisted only based on DISTRO_FEATURES, so removed those: meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb meta-oe/recipes-navigation/gypsy/gypsy.inc meta-oe/recipes-navigation/navit/navit.inc meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb * if it isn't fixed by this date, it's fair game to be removed whenever someone gets around to i Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-edbus exquisite elementary libeweather unionfs-fuse xfsprogs gmtk ↵Martin Jansa2017-02-131-0/+2
| | | | | | | | | devilspie2 gnome-backgrounds gnome-desktop gnome-mime-data gtk-engines gtksourceview2 libgnomekbd libidl-native onboard libgpewidget ubi-utils-klibc kexec-tools-klibc gupnp-igd gupnp-tools dvb-apps gstreamer mpd crda netcat-openbsd wireshark gnokii libmbim mosh networkmanager-openvpn libtelepathy dbus-daemon-proxy libdbus-c++ php vala-dbus-binding-tool collectd libgxim pywbem gtkhtml2 fbida fontforge libsexy wayland-fits xstdcmap xf86-video-glamo font-adobe-100dpi font-adobe-utopia-100dpi font-bh-100dpi font-bh-lucidatypewriter-100dpi font-misc-misc crash a2jmidid libsdl2-mixer libsdl-mixer minidlna sylpheed libsdl2-ttf libsdl-ttf ode pidgin postgresql syslog-ng usb-modeswitch xdg-user-dirs gateone python3-cryptography-vectors python3-ndg-httpsclient python-cryptography-vectors python-pbr bundler netdata menulibre openzone xfce4-verve-plugin iperf terminus-font xf86-video-nouveau ipmiutil klibc-utils pmbw multipath-tools gparted, gnome-system-monitor, php, vala-dbus-binding-tool, gtkmathview, lmsensors, postgresql: Blacklist * fails repeatedly as reported in: http://lists.openembedded.org/pipermail/openembedded-devel/2017-February/111112.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* php: Add 7.1.0Huang Qiyu2017-01-101-1/+3
| | | | | | | | | 1)Add php_7.1.0.bb 2)Delete php_5.5.38.bb,since it is replaced by php_5.6.26.bb. 3)Move pthread-check-threads-m4.patch out of 7.1.0, since it is integrated upstream. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* php: update 5.6.25Armin Kuster2016-10-031-0/+7
This update includes the following security fixes: CVE-2016-7411 CVE-2016-7412 CVE-2016-7413 CVE-2016-7414 CVE-2016-7416 CVE-2016-7417 CVE-2016-7418 plus other bug fixes. http://www.php.net/ChangeLog-5.php#5.6.26 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>