aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
Commit message (Collapse)AuthorAgeFilesLines
* rocksdb: Fix build with clang compilerKhem Raj47 min.2-0/+34
| | | | | | Need to drop using -msse4.2 -mpclmul Signed-off-by: Khem Raj <raj.khem@gmail.com>
* htop: fix Upstream-Status formatMartin Jansa47 min.1-2/+1
| | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* redis-plus-plus: Enable SSL/TLS by defaultKhem Raj47 min.1-1/+3
| | | | | | Makes the build consistent and it does not look into native sysroot for ssl Signed-off-by: Khem Raj <raj.khem@gmail.com>
* hiredis: Enable SSL/TLS support by defaultKhem Raj47 min.1-1/+5
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* smartmontools: fix Upstream-Status formatMartin Jansa4 hours1-1/+1
| | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* s-nail: fix Upstream-Status formatMartin Jansa4 hours3-3/+3
| | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* keyutils: Upgrade 1.6.1 -> 1.6.3Alex Kiernan4 hours5-13/+139
| | | | | | | | | | | Move SRC_URI to git as there's no tarball for 1.6.3. Fix failing tests when busybox is providing `head`. Pull in reproducibility fix from Arch Linux. Remove autoconf inherit as this is a simple Makefile package. Add manpages support via inherit so man-db is updated. Add missing ptest dependencies. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* msktutil: Upgrade to 1.2.1Khem Raj4 hours2-2/+34
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* dbus-cxx: Upgrade to 2.3.1Khem Raj4 hours4-81/+4
| | | | | | | | | License-Update: Swith to new license [1] Drop upstreamed patches [1] https://github.com/dbus-cxx/dbus-cxx/commit/efe8d3587104bcd748d990da8b86de9e3ef9a0ed Signed-off-by: Khem Raj <raj.khem@gmail.com>
* dbus-cxx: Fix build with gcc13Khem Raj4 hours2-0/+31
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libiodbc: Fix SRC_URI to not use gitlab archivesKhem Raj4 hours1-4/+2
| | | | | | | Fixes ERROR: libiodbc: SRC_URI uses unstable GitHub/GitLab archives, convert recipe to use git protocol [src-uri-bad] Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rdfind: Fix build with gcc13Khem Raj15 hours2-0/+55
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rdfind: Upgrade to 1.5.0 releaseKhem Raj15 hours2-3/+2
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* redis-plus-plus: Fix build with gcc13Khem Raj15 hours2-1/+39
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* redis-plus-plus: Upgrade to 1.3.7Khem Raj15 hours1-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: Upgrade to 7.9.2Khem Raj15 hours5-6/+6
| | | | | | Refresh patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: Fix build with gcc13Khem Raj15 hours2-0/+71
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vulkan-cts,opengl-es-cts: Fix build with gcc-13Khem Raj15 hours7-43/+134
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: Fix build with gcc-13Khem Raj29 hours2-0/+96
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* cups-pk-helper: add recipeMarkus Volk29 hours2-0/+47
| | | | | | | | cups-pk-helper is a runtime dependency for gnome-control-center or system-config-printer. Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libgpiod: fix python bindings buildBartosz Golaszewski29 hours2-0/+38
| | | | | | | | | | | | It seems that automake's AM_PATH_PYTHON() macro no longer sets the $PYTHON variable. This means the python bindings build for libgpiod has been broken for some time. As we know which version we're using - python3 - let's hardcode it in configure.ac. For now add a patch that's been merged upstream and once a new bugfix release is out, we'll remove it. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* edid-decode: an utility to parse EDID informationDmitry Baryshkov29 hours1-0/+17
| | | | | | | | | While parse-edid serves it's right to dump the xorg.conf style data, it lacks the ability to display most of the information found in the EDID. Add another utility to parse EDID information. Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* Nodejs: Upgrade to 18.12.1Archana Polampalli29 hours5-29/+42
| | | | | | | | | | | | | | | | | | | | | Node-18 is the current LTS release, node-19 is a development release and node-20 is scheduled to be released until 2023-04-18 which is too late for YP-4.2 https://github.com/nodejs/release * Refresh below two patches - 0001-Using-native-binaries.patch - 0001-liftoff-Correct-function-signatures.patch * Copy openssl.cnf from sysroot_native to nodejs-openssl.cnf otherwise do_compile failed: make[1]: *** No rule to make target '../deps/openssl/nodejs-openssl.cnf', needed by 'Release/obj.target/deps/openssl/openssl.cnf'. Stop. * Add initial ptest support using ctest only, it covered 20% of the nodejs tests. There are some more tests exist to add but will require additional work. Signed-off-by: Archana Polampalli <archana.polampalli@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* opensc: fix homepage URLJan Luebbe29 hours1-1/+1
| | | | | | | | | | | The opensc-project.org domain has not been active for a long time [1], so use the current wiki (which is also linked from the projects GitHub landing page). [1] https://opensc-devel.narkive.com/48b09iig/www-opensc-project-org Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* pcsc-lite: fix homepage URLJan Luebbe29 hours1-1/+1
| | | | | | | | pcsclite.alioth.debian.org is not resolvable, so use the URL indicated in the README.md file. Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* pcsc-lite: fix native buildJan Luebbe29 hours1-1/+1
| | | | | | | | | | | | The native build fails during configure with: checking for flex... no checking for lex... no configure: error: no lex or flex found Add flex-native to DEPENDS to provide it. Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* Fix missing leading whitespace with ':append'Niko Mauno29 hours3-3/+3
| | | | | | | | | Mitigate occurences where ':append' operator is used and leading whitespace character is obviously missing, risking inadvertent string concatenation. Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* cups-filters: build with dbus supportMarkus Volk29 hours1-2/+2
| | | | | Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* psqlodbc: fix HOMEPAGETrevor Woerner3 days1-1/+1
| | | | | | | | The HOMEPAGE URL is no longer valid, update it to point to the correct location. Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uutils-coreutils: upgrade 0.0.16 -> 0.0.17Etienne Cordonnier3 days1-77/+109
| | | | | Signed-off-by: Etienne Cordonnier <ecordonnier@snapchat.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* sdbus-c++: Disable ccacheKhem Raj5 days1-0/+3
| | | | | | It adds spurious -isystem from somewhere else Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uftreace: Fix a build raceKhem Raj5 days2-0/+39
| | | | | | | | | | | | | Fixes a build race seen after 0.13 upgrade | /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/git/cmds/dump.c: In function 'dump_mermaid_footer': | /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/git/cmds/dump.c:1347:10: fatal error: utils/mermaid.html.cstr: No such file or directory | 1347 | #include "utils/mermaid.html.cstr" /* This file is a converted of mermaid.html to one string literal in build-time */ | | ^~~~~~~~~~~~~~~~~~~~~~~~~ | compilation terminated. | make[1]: *** [Makefile:310: /home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/uftrace/0.13-r0/build/cmds/dump.o] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rsyslog: update to 8.2212.0Randy MacLeod5 days1-1/+1
| | | | | | | | | | | ptest results for qemux86-64/kvm with extra FS space and 1 GB RAM: Version | Passed | Failed | Skipped 8.2208 | 465 | 1 | 5 8.2212 | 470 | 0 | 5 Signed-off-by: Randy MacLeod <randy.macleod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* librelp: update to 1.11.0Randy MacLeod5 days1-2/+0
| | | | | | | | | Drop "-Wno-error", it builds fine now. Release notes: https://github.com/rsyslog/librelp/blob/master/ChangeLog Signed-off-by: Randy MacLeod <randy.macleod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* poppler: cmake: Do not use -isystemKhem Raj5 days2-0/+193
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libcereal: Use -idirafter instead of -isystemKhem Raj5 days2-0/+53
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* thrift: Fix c++ and system header include order problemKhem Raj5 days2-0/+181
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rtorrent: Add missing dependency on autoconf-archiveKhem Raj5 days1-1/+1
| | | | | | | Fixes configure errors e.g. | configure:8269: error: possibly undefined macro: PKG_CHECK_EXISTS Signed-off-by: Khem Raj <raj.khem@gmail.com>
* packagegroup-meta-oe: Remove mongodb for upsupported archesKhem Raj5 days1-0/+4
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* exiv2: Upgrade to 0.27.6Khem Raj5 days10-432/+19
| | | | | | Drop backported patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xmlsec1: Include xmlsec/parser.h for xmlSecParserSetDefaultOptions()Khem Raj5 days2-0/+44
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uw-imap: Fix build with clang 16Khem Raj5 days2-0/+179
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* espeak: Drop using 'register' keyword for storage classifierKhem Raj5 days2-0/+39
| | | | | | Fixes build with latest clang Signed-off-by: Khem Raj <raj.khem@gmail.com>
* hplip: Update to 3.22.10Khem Raj5 days3-3/+312
| | | | | | Add a patch to drop 'register' keyword Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libol: Drop recipeKhem Raj5 days3-35/+0
| | | | | | | | | | | In past it was needed by syslog-ng until it was bundled into syslog-ng and once syslog-ng was upgraded [1] this recipe became more or less unused This package is now included in the syslog-ng 1.6.x or newer release tarball [1] https://git.openembedded.org/meta-openembedded/commit/?id=1a6e16bcb1145df51b15c19df0d7ef655b683f5e Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xmlstarlet: Fix build with clang16Khem Raj5 days2-2/+35
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nspr: Fix build with clang16Khem Raj5 days2-0/+40
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rtorrent: Update to latest tip of trunkKhem Raj5 days2-115/+8
| | | | | | | | | | | | | | This is needed to get it working with latest compilers always --enable-aligned so it does not have to perform runtime test Drop the patch for removing AC_RUN_IFELSE as this macro is no longer excercised in OE builds Pin to c++14 for now, since std::binary_function is in use which is gone in c++17 ( default with clang 16+ ) License-Update: Use GPL-2.0 or later identifier correctly Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ace: Upgrade to 6.5.19Khem Raj5 days1-4/+3
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmimetic: Pin to using -std=c++14Khem Raj5 days1-1/+1
| | | | | | | | | | It uses unary_function which is removed in c++17 | ../../../git/mimetic/rfc822/header.h:37:21: error: no template named 'unary_function' in namespace 'std'; did you mean '__unary_function'? | public std::unary_function<const Field, bool> | ~~~~~^~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com>