aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-04-04 20:39:51 +0000
committerEric Bénard <eric@eukrea.com>2013-05-02 15:04:09 +0200
commitac379d426af47b75a04a3cf766481eb7a57f27d6 (patch)
treeb131643a01128fa33c1c3d3a08bec49d9de63a69
parentda595d284a85b937cefcfc34afd7ef56de16f336 (diff)
downloadmeta-openembedded-ac379d426af47b75a04a3cf766481eb7a57f27d6.tar.gz
libvpx: do not hardcode -mfloat-api=softfp for ARM builds
| Configuring for target 'armv7-linux-gcc' | enabling armv7 | enabling armv6 | enabling armv5te | enabling fast_unaligned | Unable to invoke compiler: arm-oe-linux-gnueabi-gcc -march=armv7-a -marm -mthumb-interwork -mfloat-abi=hard -mfpu=neon --sysroot=/home/hrw/HDD/devel/canonical/aarch64/openembedded/build/tmp-eglibc/sysroots/genericarmv7a -O2 -pipe -g -feliminate-unused-debug-types -fPIC -march=armv7-a -mcpu=cortex-a8 -mfpu=neon -mfloat-abi=softfp -O3 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement -Wdisabled-optimization -Wpointer-arith -Wtype-limits -Wcast-qual -Wno-unused | | Configuration failed. This could reflect a misconfiguration of your | toolchains, improper options selected, or another problem. If you | don't see any useful error messages above, the next step is to look | at the configure error log file (config.err) to determine what | configure was trying to do when it died. Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch28
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx_0.9.5.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch b/meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch
new file mode 100644
index 0000000000..d871694215
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webm/libvpx/do-not-hardcode-softfp-float-api.patch
@@ -0,0 +1,28 @@
+From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
+
+Upstream-Status: Inappopriate [upstream has it done in other way]
+
+Problem is solved upstream but we have quite old version so backporting patches
+is waste of time.
+
+---
+ build/make/configure.sh | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- libvpx-v0.9.5.orig/build/make/configure.sh
++++ libvpx-v0.9.5/build/make/configure.sh
+@@ -659,12 +659,12 @@ process_common_toolchain() {
+ if enabled iwmmxt || enabled iwmmxt2
+ then
+ check_add_asflags -mcpu=${tgt_isa}
+ elif enabled armv7
+ then
+- check_add_cflags -march=armv7-a -mcpu=cortex-a8 -mfpu=neon -mfloat-abi=softfp #-ftree-vectorize
+- check_add_asflags -mcpu=cortex-a8 -mfpu=neon -mfloat-abi=softfp #-march=armv7-a
++ check_add_cflags -march=armv7-a -mcpu=cortex-a8 -mfpu=neon #-ftree-vectorize
++ check_add_asflags -mcpu=cortex-a8 -mfpu=neon #-march=armv7-a
+ else
+ check_add_cflags -march=${tgt_isa}
+ check_add_asflags -march=${tgt_isa}
+ fi
+
diff --git a/meta-oe/recipes-multimedia/webm/libvpx_0.9.5.bb b/meta-oe/recipes-multimedia/webm/libvpx_0.9.5.bb
index 2236524897..878d5e25e3 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx_0.9.5.bb
+++ b/meta-oe/recipes-multimedia/webm/libvpx_0.9.5.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6e8dee932c26f2dab503abf70c96d8bb"
PR = "${INC_PR}.0"
SRC_URI += "file://libvpx-configure-support-blank-prefix.patch \
+ file://do-not-hardcode-softfp-float-api.patch \
file://CVE-2010-4203.patch \
"