aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordhall <dennis.hall@windriver.com>2012-11-07 19:15:21 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-11-19 11:18:30 -0500
commit4c20b896d8b709fbaed8888da98e81de74292b90 (patch)
tree1eeea2071b5ef7b78bf4d9ed39e40948475fb22a
parentb38e0815204007873116bb657d9943c7f0206fb2 (diff)
downloadmeta-openembedded-4c20b896d8b709fbaed8888da98e81de74292b90.tar.gz
aoetools: add a recipe for version 34
Add the aoetools (ATA over Ethernet) package to be used along with a kernel module(aoe.ko) and server software(vblade) to support ATA over ethernet network storage. Signed-off-by: dhall <dennis.hall@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
-rw-r--r--meta-networking/recipes-support/aoetools/aoetools_34.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/aoetools/aoetools_34.bb b/meta-networking/recipes-support/aoetools/aoetools_34.bb
new file mode 100644
index 0000000000..07bfb0f155
--- /dev/null
+++ b/meta-networking/recipes-support/aoetools/aoetools_34.bb
@@ -0,0 +1,25 @@
+SUMMARY = "ATA over Ethernet Tools"
+DESCRIPTION = " \
+The aoetools are programs for users of the ATA over Ethernet (AoE)network \
+storage protocol, a simple protocol for using storage over anethernet LAN. \
+The vblade program (storage target) exports a blockdevice using AoE. \
+"
+HOMEPAGE = "http://sourceforge.net/projects/${PN}"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+RRECOMMENDS_${PN} = "kernel-module-aoe"
+PR = "r0"
+
+
+SRC_URI = "http://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${PN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "cde7f7cedc7cd9938a5ebfd009dd3ec0"
+SRC_URI[sha256sum] = "fd6c57244e9458d7cbe7a0171295ddee4d8cdcae291e40d6acbc641df7296d85"
+
+# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
+# the -e causes problems as CFLAGS is modified in the Makefile.
+EXTRA_OEMAKE = ""
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}