aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-06 10:24:33 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-06 10:24:40 +0200
commit5b27dc8974cbd4fd769ed61d9287bedc63d2a644 (patch)
treefa0218071b48d9ce59788515d400715023e8a64b
parentaccc0d62ae67e36acfed8a469f0deea716d9de70 (diff)
downloadmeta-openembedded-5b27dc8974cbd4fd769ed61d9287bedc63d2a644.tar.gz
systemd: bump SRCREV and fix postinst
The u-a class gets in the way of the addgroup, so do things manually Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb23
1 files changed, 9 insertions, 14 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index f6c675273e..6a9d864975 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -17,9 +17,9 @@ PKGV = "v${GITPKGVTAG}"
PV = "git"
PR = "r4"
-inherit autotools vala update-alternatives
+inherit autotools vala
-SRCREV = "9a66640832d103f906c2ef609a1d19d43fc542f6"
+SRCREV = "78e39b43b89c6bf9ce401d6030939a004a23c850"
SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \
file://execute.patch \
@@ -54,11 +54,6 @@ do_install_append() {
fi
}
-ALTERNATIVE_NAME = "init"
-ALTERNATIVE_LINK = "${base_sbindir}/init"
-ALTERNATIVE_PATH = "${base_bindir}/systemd"
-ALTERNATIVE_PRIORITY = "80"
-
PACKAGES =+ "${PN}-gui ${PN}-serialgetty"
FILES_${PN}-gui = "${bindir}/systemadm"
@@ -101,17 +96,17 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \
# u-a for runlevel and telinit
pkg_postinst_${PN} () {
-# can't do this offline, but we need the u-a bits
-if [ "x$D" != "x" ]; then
- echo "can't do addgroup offline"
-else
- grep "^lock:" /etc/group > /dev/null || addgroup lock
-fi
-
+update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300
update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
+# can't do this offline, but we need the u-a bits above
+if [ "x$D" != "x" ]; then
+ echo "can't do addgroup offline" ; exit 1
+else
+ grep "^lock:" /etc/group > /dev/null || addgroup lock
+fi
}