aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-28 11:42:40 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-28 11:42:40 +0100
commite32e4c95a80efe06a37371ccdabc432824479174 (patch)
tree9e3ee2d23db95d8fd588bf5bec968de5ab4f1a15
parentec109f573b2018aa607300539f4b1e3ad17850b1 (diff)
downloadmeta-openembedded-e32e4c95a80efe06a37371ccdabc432824479174.tar.gz
libusb-compat: convert to bbappend
-rw-r--r--recipes-support/libusb/libusb-compat-0.1.3/gcc-3-compatibility.patch26
-rw-r--r--recipes-support/libusb/libusb-compat_0.1.3.bb23
-rw-r--r--recipes-support/libusb/libusb-compat_0.1.3.bbappend4
3 files changed, 4 insertions, 49 deletions
diff --git a/recipes-support/libusb/libusb-compat-0.1.3/gcc-3-compatibility.patch b/recipes-support/libusb/libusb-compat-0.1.3/gcc-3-compatibility.patch
deleted file mode 100644
index e6142f735c..0000000000
--- a/recipes-support/libusb/libusb-compat-0.1.3/gcc-3-compatibility.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: libusb-compat-0.1.2/configure.ac
-===================================================================
---- libusb-compat-0.1.2.orig/configure.ac 2009-06-11 22:49:08.000000000 +0000
-+++ libusb-compat-0.1.2/configure.ac 2009-06-26 21:44:08.000000000 +0000
-@@ -56,7 +56,7 @@
- CFLAGS="$saved_cflags"
-
- AC_DEFINE([API_EXPORTED], [__attribute__((visibility("default")))], [Default visibility])
--AM_CFLAGS="-std=gnu99 $inline_cflags -Wall -Wundef -Wunused -Wstrict-prototypes -Werror-implicit-function-declaration -Wno-pointer-sign -Wshadow"
-+AM_CFLAGS="-std=gnu99 $inline_cflags -Wall -Wundef -Wunused -Wstrict-prototypes -Werror-implicit-function-declaration -Wshadow"
- AC_SUBST(AM_CFLAGS)
-
- AC_CONFIG_FILES([libusb.pc] [libusb-config] [Makefile] [libusb/Makefile] [examples/Makefile])
-Index: libusb-compat-0.1.2/libusb/Makefile.am
-===================================================================
---- libusb-compat-0.1.2.orig/libusb/Makefile.am 2008-06-17 23:13:02.000000000 +0000
-+++ libusb-compat-0.1.2/libusb/Makefile.am 2009-06-26 21:44:08.000000000 +0000
-@@ -2,7 +2,7 @@
- lib_LTLIBRARIES = libusb.la
-
- libusb_la_SOURCES = core.c usbi.h
--libusb_la_CFLAGS = -fvisibility=hidden $(AM_CFLAGS) $(LIBUSB_1_0_CFLAGS)
-+libusb_la_CFLAGS = $(AM_CFLAGS) $(LIBUSB_1_0_CFLAGS)
- libusb_la_LIBADD = $(LIBUSB_1_0_LIBS)
- libusb_la_LDFLAGS = -version-info $(LT_MAJOR):$(LT_REVISION):$(LT_AGE) \
- -release 0.1
diff --git a/recipes-support/libusb/libusb-compat_0.1.3.bb b/recipes-support/libusb/libusb-compat_0.1.3.bb
deleted file mode 100644
index b2880eb78d..0000000000
--- a/recipes-support/libusb/libusb-compat_0.1.3.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "libusb-0 compatibility library using libusb-1"
-HOMEPAGE = "http://libusb.sf.net"
-SECTION = "libs"
-
-LICENSE = "LGPLv2.1+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f2ac5f3ac4835e8f91324a26a590a423"
-
-PROVIDES = "virtual/libusb0"
-PE = "1"
-PR = "r0"
-
-DEPENDS = "libusb1"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/${P}.tar.bz2;name=libusbcompat013tarbz2"
-SRC_URI[libusbcompat013tarbz2.md5sum] = "570ac2ea085b80d1f74ddc7c6a93c0eb"
-SRC_URI[libusbcompat013tarbz2.sha256sum] = "a590a03b6188030ee1ca1a0af55685fcde005ca807b963970f839be776031d94"
-
-SRC_URI_append_nylon = " file://gcc-3-compatibility.patch"
-
-inherit autotools binconfig lib_package
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-EXTRA_OECONF = "--disable-build-docs"
diff --git a/recipes-support/libusb/libusb-compat_0.1.3.bbappend b/recipes-support/libusb/libusb-compat_0.1.3.bbappend
new file mode 100644
index 0000000000..fdb0b5d3d9
--- /dev/null
+++ b/recipes-support/libusb/libusb-compat_0.1.3.bbappend
@@ -0,0 +1,4 @@
+PROVIDES = "virtual/libusb0"
+
+inherit lib_package
+