aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2012-09-17 10:58:09 +0000
committerEric Bénard <eric@eukrea.com>2012-12-16 10:50:26 +0100
commit0f17a3fb00c3cef39c09fb51575bcb9d37f09f5b (patch)
tree0a71c168ec16ddee77e1adfab3b789da6a28ee2a
parentd6dd53c3b69e341a1f5102d9e88bb72d07d0e33d (diff)
downloadmeta-openembedded-0f17a3fb00c3cef39c09fb51575bcb9d37f09f5b.tar.gz
meta-systemd: systemd-systemctl-native: Also add support for WantedBy=*.service
Right now there was only WantedBy=*.target, which prevented some services from beeing installed, which prevent them from running at boot. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-core/systemd/systemd-systemctl-native.bb2
-rwxr-xr-xmeta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
index 25ddbdadec..59405842e9 100644
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r5"
+PR = "r6"
inherit native
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
index 196e7295d5..6b8832b1ec 100755
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
@@ -81,7 +81,7 @@ for service in $services; do
wanted_by=$(grep WantedBy $ROOT/$service_file \
| sed 's,WantedBy=,,g' \
| tr ',' '\n' \
- | grep '\.target$')
+ | grep '\(\.target$\)\|\(\.service$\)')
for r in $wanted_by; do
echo "WantedBy=$r found in $service"