aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-07-13 09:11:51 +0000
committerEric Bénard <eric@eukrea.com>2012-07-13 11:27:17 +0200
commit10f443c2cd18a786f5974d85e1e428e38cdb8c96 (patch)
tree28527b6e1d504a7cbb1ca374c62414f87cfa1f12
parent372f86378b29aeddfe5aa52a43a9fa7528eda614 (diff)
downloadmeta-openembedded-10f443c2cd18a786f5974d85e1e428e38cdb8c96.tar.gz
nodejs: update to 0.6.18 and fix hardfloat detection
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch22
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.6.18.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_0.6.17.bb)12
2 files changed, 29 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch b/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch
new file mode 100644
index 0000000000..36e8bf1c97
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch
@@ -0,0 +1,22 @@
+Fix hardfloat detection
+
+gcc has a builtin define to denote hard abi when in use, e.g. when
+using -mfloat-abi=hard it will define __ARM_PCS_VFP to 1 and therefore
+we should check that to determine which calling convention is in use
+and not __VFP_FP__ which merely indicates presence of VFP unit
+
+The fix has been provided by Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Forwarded
+
+--- a/deps/v8/src/platform-linux.cc 2012-05-17 12:52:59.329519921 -0700
++++ b/deps/v8/src/platform-linux.cc 2012-05-17 12:54:02.037521511 -0700
+@@ -212,7 +212,7 @@
+ // calling this will return 1.0 and otherwise 0.0.
+ static void ArmUsingHardFloatHelper() {
+ asm("mov r0, #0");
+-#if defined(__VFP_FP__) && !defined(__SOFTFP__)
++#if defined(__ARM_PCS_VFP) && !defined(__SOFTFP__)
+ // Load 0x3ff00000 into r1 using instructions available in both ARM
+ // and Thumb mode.
+ asm("mov r1, #3");
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.17.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.18.bb
index 1be5ce1d58..d5785d25da 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.17.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.18.bb
@@ -5,9 +5,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=914812f2875eef849b5c509cc25dcb4f"
DEPENDS = "openssl"
-SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-SRC_URI[md5sum] = "55641d5d280cdd4e0c030c203107599d"
-SRC_URI[sha256sum] = "8dfe5948de27e37a14af184f06e7bd89a23c3b248af44c8ef5cffcd0e4c65778"
+SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
+ file://gcc-4.7.patch"
+
+SRC_URI[md5sum] = "4a3d3123ccc7b9b21c1990fe074e3d14"
+SRC_URI[sha256sum] = "6cf4311ecbc1700e88f4382a31b3a7017c1572cd641fd06e653fc1692c2cffff"
S = "${WORKDIR}/node-v${PV}"
@@ -42,14 +44,14 @@ do_configure () {
}
do_compile_virtclass-native () {
- make
+ make BUILDTYPE=Release
}
do_compile () {
export PATH=${WORKDIR}:${PATH}
export CC=gcc
export CXX=g++
- make
+ make BUILDTYPE=Release
}
do_install () {