aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-27 12:57:15 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-27 21:58:08 +0200
commit75cf830027c3da7262d9be86f3f79ab64126db78 (patch)
tree0383bfa3c85ebfa9130567b0e0039d20e680583c
parent916cfb4b0e474ca34e664f65316cc54198b3d73f (diff)
downloadmeta-openembedded-75cf830027c3da7262d9be86f3f79ab64126db78.tar.gz
busybox 1.19.4 bbapped: create dir before installing into it, fixes build failures on the autobuilder
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend b/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
index 2c73732400..786e1d52d5 100644
--- a/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
+++ b/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
@@ -1,6 +1,6 @@
inherit systemd
-PRINC := "${@int(PRINC) + 3}"
+PRINC := "${@int(PRINC) + 4}"
# look for files in the layer first
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -16,6 +16,7 @@ do_install_append() {
install -d ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog
+ install -d ${D}${systemd_unitdir}/system
sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
> ${D}${systemd_unitdir}/system/busybox-syslog.service
sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \