aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-03-09 15:21:14 -0400
committerArmin Kuster <akuster808@gmail.com>2015-03-26 15:20:38 -0700
commit30438e7690a7e44ce216478c0352a3fbf3b572fb (patch)
tree94dda1cc50a742f3821d66e9c61f331af317c889
parent78e2b42af5aff3affe266d5a9639aa14a20a732b (diff)
downloadmeta-openembedded-30438e7690a7e44ce216478c0352a3fbf3b572fb.tar.gz
sip: Split python into a new package for runtime support.
The package is named python-sip for backwards compatibility. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/sip/sip_4.16.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sip/sip_4.16.4.bb b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
index 2a2674f918..d6d3f9ca5c 100644
--- a/meta-oe/recipes-extended/sip/sip_4.16.4.bb
+++ b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
@@ -15,6 +15,8 @@ SRC_URI[sha256sum] = "ceda443fc5e129e67a067e2cd7b73ff037f8b10b50e407baa2b1d9f219
BBCLASSEXTEND = "native"
inherit qmake2 python-dir pythonnative
+PACKAGES += "python-sip"
+
EXTRA_QMAKEVARS_POST += "CONFIG=console"
@@ -45,6 +47,6 @@ do_install() {
oe_runmake install
}
-FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages/"
+FILES_python-${PN} = "${libdir}/${PYTHON_DIR}/site-packages/"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"