aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:26:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:35:29 +0100
commit5768dda687dd23a0ffb2c45d432cd2f609875ad1 (patch)
tree0a9de70a70189486e6a0d068448cb4d52f38e52f
parent511cdb8182b29e397d11a05b2dec5b8c6e828051 (diff)
downloadmeta-openembedded-5768dda687dd23a0ffb2c45d432cd2f609875ad1.tar.gz
ktap: add libelf PACKAGECONFIG also to ktap-module
* building ktap-module without elfutils fails with: ktap-module/0.4-r0/git/Makefile:107: No libelf found, disables symbol resolving, please install elfutils-libelf-devel/libelf-dev Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb5
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc12
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb11
3 files changed, 14 insertions, 14 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
index 62f2a99a25..64648b0157 100644
--- a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
@@ -6,11 +6,8 @@ SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
inherit module
-# Available package configs: ffi (only supported on x86_64)
-PACKAGECONFIG ?= ""
-
# Only build the module
-MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
+MAKE_TARGETS = "mod"
# Kernel module packages MUST begin with 'kernel-module-', otherwise
# multilib image generation can fail.
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
index 93a4e2ca32..72538bc84f 100644
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -10,4 +10,16 @@ SRC_URI = "git://github.com/ktap/ktap.git"
S = "${WORKDIR}/git"
# Package config is abused as a general compile time configuration tool.
+
+# Only supports x86_64 for now!. Needs to be enabled for ktap-module too.
PACKAGECONFIG[ffi] = ""
+
+# Needed to resolve symbols in DSO and for sdt
+PACKAGECONFIG[libelf] = ",,elfutils"
+
+PACKAGECONFIG ?= "libelf"
+
+EXTRA_OEMAKE = " \
+ ${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
+ ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
+"
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
index cbdabf82d8..eb2bf651d7 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -5,17 +5,8 @@ require ktap.inc
SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
DEPENDS = "ktap-module"
-#Available package configs:
-# libelf - needed to resolve symbols in DSO and for sdt
-# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
-PACKAGECONFIG ?= "libelf"
-
-PACKAGECONFIG[libelf] = ",,elfutils"
-
# Only build the userspace app
-EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
- ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
- ktap"
+EXTRA_OEMAKE += "ktap"
do_install() {
install -d ${D}${bindir}