aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2013-12-16 11:31:37 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-04 11:56:41 +0100
commit5683b166de80a8225ddf286e5437f2c4f1a02aff (patch)
treeeba73deed82f9bbce3226dc51791136af0a8a19a
parent91d5ca10059361655ba20d1da54cf98c8d93c1a9 (diff)
downloadmeta-openembedded-5683b166de80a8225ddf286e5437f2c4f1a02aff.tar.gz
bash-completion: add recipe
This new recipe discards the old recipe in OE-Classic: http://layers.openembedded.org/layerindex/oe-classic/recipe/16369/ When building ready-to-use images (like .vmdk), it is sometimes convenient to have a fancy shell environment. Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb b/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
new file mode 100644
index 0000000000..411b9b7e17
--- /dev/null
+++ b/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Programmable Completion for Bash 4"
+HOMEPAGE = "http://bash-completion.alioth.debian.org/"
+BUGTRACKER = "https://alioth.debian.org/projects/bash-completion/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SECTION = "console/utils"
+
+SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "0d903f398be8c8f24bc5ffa6f86127f8"
+SRC_URI[sha256sum] = "e5a490a4301dfb228361bdca2ffca597958e47dd6056005ef9393a5852af5804"
+
+inherit allarch autotools
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/bash_completion.d/
+ echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
+}
+
+RDEPENDS_${PN} = "bash"
+
+# Some recipes are providing ${PN}-bash-completion packages
+PACKAGES =+ "${PN}-extra"
+FILES_${PN}-extra = "${datadir}/${BPN}/completions/ \
+ ${datadir}/${BPN}/helpers/"