aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2013-09-24 12:43:57 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:23 +0200
commit73a68490efe05cdbec540ec6f17782816632a24d (patch)
tree7eea1efa44b2eab8c5dfebcc2f5a2fcfc653802f
parent6fd61c04df134fc9bbad03614d301256124250a8 (diff)
downloadmeta-openembedded-73a68490efe05cdbec540ec6f17782816632a24d.tar.gz
wvdial: add recipe for version 1.61
Recipe based on OE classic's recipe for version 1.60, as of ff0d06489db2e50353d72d24aada74c60bddb016. Summary of changes against OE classic's recipe: * Apply typo_pon.wvdial.1.patch patch from Debian's http://patch-tracker.debian.org/package/wvdial/1.61-4.1 * Fix Makefile in do_configure task * Add wvstreams' include dir to BUILD_CPPFLAGS * Minor adjustments for the current build system (add LIC_FILES_CHKSUM, md5 and sha256 sums for SRC_URI, fix LICENSE, remove PR) * Disable parallel make, since it was causing errors like Log data follows: | DEBUG: Executing shell function do_compile | NOTE: make -j 8 | * Generating CC | ./CXX -c wvdialer | * Generating CXX | ./CXX -c wvmodemscan | /bin/bash: ./CXX: No such file or directory | make: *** [wvdialer.o] Error 127 | make: *** Waiting for unfinished jobs.... | make: *** wait: No child processes. Stop. | ERROR: oe_runmake failed | WARNING: .../tmp/work/armv7a-vfp-neon-oel-linux-gnueabi/wvdial/1.61-r0/temp/run.do_compile.18676:1 exit 1 from | exit 1 Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch20
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb30
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch b/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch
new file mode 100644
index 0000000000..eec5a5d646
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch
@@ -0,0 +1,20 @@
+Remove warnings found by lintian
+Last-Update: 2011-01-09
+Index: wvdial-1.61/pon.wvdial.1
+===================================================================
+--- wvdial-1.61.orig/pon.wvdial.1 2011-01-09 21:33:03.000000000 +0300
++++ wvdial-1.61/pon.wvdial.1 2011-01-09 21:33:15.000000000 +0300
+@@ -8,13 +8,11 @@
+ .SH DESCRIPTION
+ .B pon.wvdial
+ .br
+-.TR
+ .B poff.wvdial
+ .br
+ .RS
+ Replacement scripts for pon and poff.
+ .RE
+-\."
+ .SH SEE ALSO
+ .BR wvdial (1),
+ .BR pon (1),
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
new file mode 100644
index 0000000000..af1ebf3024
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
@@ -0,0 +1,30 @@
+HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
+DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
+
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
+
+DEPENDS = "wvstreams"
+RDEPENDS_${PN} = "ppp"
+
+SRC_URI = "http://${PN}.googlecode.com/files/${PN}-${PV}.tar.bz2 \
+ file://typo_pon.wvdial.1.patch \
+ "
+
+SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de"
+SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82"
+
+EXTRA_OEMAKE = ""
+export WVLINK="${LD}"
+
+PARALLEL_MAKE = ""
+
+BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams"
+
+do_configure() {
+ sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile
+}
+
+do_install() {
+ oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
+}