aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2021-09-20 17:12:26 +0200
committerArmin Kuster <akuster808@gmail.com>2021-09-20 15:52:10 -0700
commit5368c7c63d0703ba9e2b64307d97778481038ccd (patch)
tree882d68ef55adc652f9e495e0d9f168dc7f6d18cf
parentb06724bc274f751004ade2ceeddfb8ec40d93f16 (diff)
downloadmeta-openembedded-5368c7c63d0703ba9e2b64307d97778481038ccd.tar.gz
dstat: Add missing python-six runtime dependency
The tool depends on the six module, add it, otherwise the following traceback happens when running it on the target: Traceback (most recent call last): File "/usr/bin/dstat", line 32, in <module> import six ModuleNotFoundError: No module named 'six' Signed-off-by: Marek Vasut <marex@denx.de> Cc: Khem Raj <raj.khem@gmail.com> Cc: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/dstat/dstat_0.7.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/dstat/dstat_0.7.4.bb b/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
index 74af54ca53..0e314b8ee5 100644
--- a/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
+++ b/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
@@ -21,4 +21,4 @@ do_install() {
oe_runmake 'DESTDIR=${D}' install
}
-RDEPENDS_${PN} += "python3-core python3-misc python3-resource python3-shell python3-unixadmin"
+RDEPENDS_${PN} += "python3-core python3-misc python3-resource python3-shell python3-six python3-unixadmin"