aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-05-16 08:11:53 -0700
committerArmin Kuster <akuster808@gmail.com>2020-05-28 21:16:38 -0700
commit716cd27ec045f82929d0c2c3b976286481a57388 (patch)
treeeff0fbdca345c2fc5bff774517bbbfa3be31e15a
parente413c1ef621688e69bb7830bb3151ed23b30b73e (diff)
downloadmeta-openembedded-716cd27ec045f82929d0c2c3b976286481a57388.tar.gz
netplan: Depend on systemd if it is in distro
it needs to link with libsystemd when using systemd as init system Fixes Package libsystemd was not found in the pkg-config search path. Perhaps you should add the directory containing `libsystemd.pc' to the PKG_CONFIG_PATH environment variable Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 60e603f11ae1cca38553d18cf411f1a77207a97c) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.98.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb
index db029a4b8a..9f123c70fb 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb
@@ -18,7 +18,8 @@ SRC_URI = " \
git://github.com/CanonicalLtd/netplan.git \
"
-DEPENDS = "glib-2.0 libyaml"
+DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+
RDEPENDS_${PN} = "python3 python3-core python3-pyyaml python3-netifaces python3-nose python3-coverage python3-pycodestyle python3-pyflakes util-linux-libuuid"
inherit pkgconfig systemd