aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-04 12:32:53 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-04 20:36:47 +0200
commit294a0b5cee0ccb752a73092d4548dac0ecc6c4c4 (patch)
tree67285797f5a9ac1963bee18ffa1a9a5c11b855f2
parent41df85603a924e3c31c21c90df3478bb082b44d1 (diff)
downloadmeta-openembedded-294a0b5cee0ccb752a73092d4548dac0ecc6c4c4.tar.gz
openmotif: add 2.3.3
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-support/openmotif/openmotif/configure.patch15
-rw-r--r--meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb38
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openmotif/openmotif/configure.patch b/meta-oe/recipes-support/openmotif/openmotif/configure.patch
new file mode 100644
index 0000000000..8868e805a4
--- /dev/null
+++ b/meta-oe/recipes-support/openmotif/openmotif/configure.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac~ 2009-10-27 14:10:23.000000000 -0200
++++ b/configure.ac 2011-05-31 10:51:00.207232036 -0300
+@@ -3,12 +3,6 @@
+ AC_CONFIG_SRCDIR([lib/Xm/Form.c])
+ AC_PREREQ(2.52)
+ AC_CONFIG_AUX_DIR(.)
+-AC_CHECK_FILE(/usr/X/include/X11/X.h,
+- AC_PREFIX_DEFAULT(/usr/X),
+- AC_PREFIX_DEFAULT(/usr))
+-AC_CHECK_FILE(/usr/X11R6/include/X11/X.h,
+- AC_PREFIX_DEFAULT(/usr/X11R6),
+- AC_PREFIX_DEFAULT(/usr))
+
+ dnl AM_MAINTAINER_MODE
+ AC_CANONICAL_TARGET
diff --git a/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb b/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb
new file mode 100644
index 0000000000..2e9c2de9f6
--- /dev/null
+++ b/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb
@@ -0,0 +1,38 @@
+SECTION = "libs"
+DESCRIPTION = "OSM/Motif implementation."
+LICENSE = "OGPL"
+DEPENDS = "xbitmaps virtual/libx11 libxt libxp"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=14f692c82491db3d52419929d2f3b343"
+
+SRC_URI = "http://openmotif.com/files/public_downloads/openmotif/2.3/2.3.3/openmotif-2.3.3.tar.gz \
+ file://configure.patch;patch=1"
+
+SRC_URI[md5sum] = "fd27cd3369d6c7d5ef79eccba524f7be"
+SRC_URI[sha256sum] = "c85f5545e218fa0c59a3789192132d472fc5a33e914a221a568eee4fc10cd103"
+
+inherit autotools
+
+PACKAGES += "${PN}-bin"
+
+FILES_${PN}-bin = "${bindir}"
+
+do_compile() {
+ (
+ # HACK: build a native binaries need during the build
+ unset CC LD CXX CCLD CFLAGS
+ oe_runmake -C config/util CC="${BUILD_CC}" LD="${BUILD_LD}" CXX="${BUILD_CXX}" LIBS="" makestrs
+ )
+ if [ "$?" != "0" ]; then
+ exit 1
+ fi
+ oe_runmake -C lib
+ oe_runmake -C include
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} -C lib install
+ oe_runmake DESTDIR=${D} -C include install
+}
+
+LEAD_SONAME = "libXm.so.4"