aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-11-19 14:14:38 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-04 12:08:36 +0100
commitb08b6d79ae52ae169f08c6d8af155bbb1bb21d83 (patch)
treeb325e37f5d8e3ba3b8a41ba59d35422dab2dc2b4
parentdc22e75aedabb5e86641b172bbcf273f8ca7480e (diff)
downloadmeta-openembedded-b08b6d79ae52ae169f08c6d8af155bbb1bb21d83.tar.gz
fbset-modes: Explicitly set MACHINE_ARCH
* bitbake-diffsigs output: basehash changed from 2f6aa4302713441e9c3c7207c4edea33 to 3486f2b65998ee4ec5bd5fbbe02cadb0 List of dependencies for variable TARGET_LD_ARCH changed from 'set([])' to 'set(['TUNE_LDARGS'])' List of dependencies for variable TARGET_AS_ARCH changed from 'set([])' to 'set(['TUNE_ASARGS'])' List of dependencies for variable TARGET_OS changed from 'set([])' to 'set(['ABIEXTENSION', 'LIBCEXTENSION'])' List of dependencies for variable TARGET_CC_ARCH changed from 'set([])' to 'set(['TUNE_CCARGS'])' List of dependencies for variable TARGET_ARCH changed from 'set([])' to 'set(['TUNE_ARCH'])' Dependency on Variable ABIEXTENSION was removed Dependency on Variable TUNE_CCARGS was removed Dependency on Variable TUNE_FEATURES_tune-armv5t was removed Dependency on Variable TUNE_FEATURES_tune-armv5te was removed Dependency on Variable TUNE_ARCH was removed Dependency on Variable LIBCEXTENSION was removed Dependency on Variable TUNE_FEATURES_tune-armv5 was removed Dependency on Variable TUNE_LDARGS was removed Dependency on Variable DEFAULTTUNE was removed Dependency on Variable TUNE_ASARGS was removed Dependency on Variable TUNE_FEATURES was removed Variable TARGET_LD_ARCH value changed from 'none' to '${TUNE_LDARGS}' Variable TARGET_AS_ARCH value changed from 'none' to '${TUNE_ASARGS}' Variable TARGET_OS value changed from 'linux' to 'linux${LIBCEXTENSION}${ABIEXTENSION}' Variable TARGET_CC_ARCH value changed from 'none' to '${TUNE_CCARGS}' Variable TARGET_ARCH value changed from 'allarch' to '${TUNE_ARCH}' Hash for dependent task fbset-modes.bb.do_patch changed from eb8e475b55d64d5c9f6427a90e080ba6 to ee7e89fdd852378ee18ac23cdd92f3d3
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset-modes.bb b/meta-oe/recipes-support/fbset/fbset-modes.bb
index 03d4039509..e3b26ec451 100644
--- a/meta-oe/recipes-support/fbset/fbset-modes.bb
+++ b/meta-oe/recipes-support/fbset/fbset-modes.bb
@@ -13,5 +13,9 @@ do_install() {
}
inherit allarch
-CONFFILES_${PN} = "${sysconfdir}/fb.modes"
+# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
+# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CONFFILES_${PN} = "${sysconfdir}/fb.modes"