aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2015-03-10 16:20:08 +1100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-10 14:19:36 +0100
commitbdac062c685f40fe07e5d799d7486f347fe8976a (patch)
tree63babec3acdd142fe3849e5ea6b8641eb68e3760
parent74bbde6984082ec5d32bc06d1abd41212503553b (diff)
downloadmeta-openembedded-bdac062c685f40fe07e5d799d7486f347fe8976a.tar.gz
nodejs: remove curl from RDEPENDS
curl is only needed to run "make test". Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.12.0.bb3
1 files changed, 0 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.0.bb
index b514837a1d..cefc0bcc98 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.0.bb
@@ -66,9 +66,6 @@ do_install_append_class-target() {
sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${libdir}/node_modules/npm/bin/npm-cli.js
}
-RDEPENDS_${PN} = "curl"
-RDEPENDS_${PN}_class-native = ""
-
PACKAGES =+ "${PN}-npm"
FILES_${PN}-npm = "${libdir}/node_modules ${bindir}/npm"
RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils"