aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Baryshkov <dbaryshkov@gmail.com>2021-01-07 03:54:17 +0300
committerArmin Kuster <akuster808@gmail.com>2021-01-18 08:38:04 -0800
commita653238398d483c805c3d026d890162f131ecc01 (patch)
tree1def73b12baf3da79c0c9dbecaf1d83b45792f09
parent6ff4bd4f345b4e8030b9197d13097308df521576 (diff)
downloadmeta-openembedded-a653238398d483c805c3d026d890162f131ecc01.tar.gz
xterm: install xterm and uxterm desktop files
Modify recipe to install application desktop files for xterm. Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 593f21eda5b119f6408975c6b15e94fb168cc9dc)
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xterm_353.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm_353.bb b/meta-oe/recipes-graphics/xorg-app/xterm_353.bb
index 6de704d0b7..6376388c27 100644
--- a/meta-oe/recipes-graphics/xorg-app/xterm_353.bb
+++ b/meta-oe/recipes-graphics/xorg-app/xterm_353.bb
@@ -1,6 +1,6 @@
require recipes-graphics/xorg-app/xorg-app-common.inc
SUMMARY = "xterm is the standard terminal emulator for the X Window System"
-DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses"
+DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses desktop-file-utils-native"
LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=996b1ce0584c0747b17b57654cc81e8e"
@@ -13,6 +13,9 @@ SRC_URI[sha256sum] = "e521d3ee9def61f5d5c911afc74dd5c3a56ce147c7071c74023ea24cac
PACKAGECONFIG ?= ""
PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
+# Let xterm install .desktop files
+inherit mime-xdg
+
EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
--x-libraries=${STAGING_LIBDIR} \
FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
@@ -30,6 +33,10 @@ do_configure() {
oe_runconf
}
+do_install_append() {
+ oe_runmake install-desktop DESTDIR="${D}" DESKTOP_FLAGS="--dir=${D}${DESKTOPDIR}"
+}
+
# busybox can supply resize too
inherit update-alternatives