aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Fan Yu <yifan.yu@windriver.com>2021-04-16 11:36:48 -0400
committerArmin Kuster <akuster808@gmail.com>2021-04-18 13:49:13 -0700
commitf5d3ba9fec8e4d5a261f2ce470a785c50e4615ca (patch)
treec990dd16d911f4d36c5631d2704480aef17d2124
parent315b75d0c5b9049c7e987b701a900aad3db0426f (diff)
downloadmeta-openembedded-f5d3ba9fec8e4d5a261f2ce470a785c50e4615ca.tar.gz
syslog-ng: remove CONFIG_TLS override for arm DEBUG_BUILD
when enabling DEBUG_BUILD, an assembler failure used to be seen. But this patch was in meta-oe c0ce7599, dating in 2014... Cannot reproduce the failure anymore with qemuarm. Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 6c626c0e12673b56ed2d7387465f8c2d88d956d2) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch63
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc5
2 files changed, 0 insertions, 68 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
deleted file mode 100644
index ff35fb157c..0000000000
--- a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 15a90fd9ac1396015340e599e26d7cd193898fb8 Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Tue, 12 Aug 2014 14:26:13 +0800
-Subject: [PATCH] configure.ac: add option --enable-thread-tls to manage thread
- ssl support
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The thread local storage caused arm-gcc broken while compiling │
-syslog-ng with option '-g -O'. │
-... │
-dnscache.s: Assembler messages: │
-dnscache.s:100: Error: invalid operands (.text and *UND* sections) for `-' │
-... │
- │
-Add option --enable-thread-tls to manage the including of thread
-local storage, so we could explicitly disable it.
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-
-change default to 'yes'
-Upstream-Status: Submitted [https://github.com/syslog-ng/syslog-ng/pull/3649]
-
-Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
----
- configure.ac | 16 ++++++++++------
- 1 file changed, 10 insertions(+), 6 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 1d67e81..7aad75f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -210,6 +210,8 @@ AC_ARG_WITH(sanitizer,
- [ --with-sanitizer=[address/undefined/etc...]
- Enables compiler sanitizer supports (default: no)]
- ,,with_sanitizer="no")
-+AC_ARG_ENABLE(thread-tls,
-+ [ --enable-thread-tls Enable Thread Local Storage support (default: yes)],,enable_thread_tls="yes")
-
- AC_ARG_ENABLE(dynamic-linking,
- [ --enable-dynamic-linking Link everything dynamically.],,enable_dynamic_linking="auto")
-@@ -628,12 +630,14 @@ dnl ***************************************************************************
- dnl Is the __thread keyword available?
- dnl ***************************************************************************
-
--AC_LINK_IFELSE([AC_LANG_PROGRAM(
--[[#include <pthread.h>
--__thread int a;
--]],
--[a=0;])],
--[ac_cv_have_tls=yes; AC_DEFINE_UNQUOTED(HAVE_THREAD_KEYWORD, 1, "Whether Thread Local Storage is supported by the system")])
-+if test "x$enable_thread_tls" = "xyes"; then
-+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
-+ [[#include <pthread.h>
-+ __thread int a;
-+ ]],
-+ [a=0;])],
-+ [ac_cv_have_tls=yes; AC_DEFINE_UNQUOTED(HAVE_THREAD_KEYWORD, 1, "Whether Thread Local Storage is supported by the system")])
-+fi
-
- dnl ***************************************************************************
- dnl How to do static linking?
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index ebb3eaf0fc..e48e5d5e2f 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -22,7 +22,6 @@ SRC_URI = "https://github.com/balabit/syslog-ng/releases/download/${BP}/${BP}.ta
file://syslog-ng.conf.sysvinit \
file://initscript \
file://volatiles.03_syslog-ng \
- file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \
"
UPSTREAM_CHECK_URI = "https://github.com/balabit/syslog-ng/releases"
@@ -42,12 +41,8 @@ EXTRA_OECONF = " \
--disable-python \
--disable-java --disable-java-modules \
--with-pidfile-dir=${localstatedir}/run/${BPN} \
- ${CONFIG_TLS} \
"
-CONFIG_TLS = "--enable-thread-tls"
-CONFIG_TLS_arm = "${@oe.utils.conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}"
-
PACKAGECONFIG ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} \
"