aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Hieber <rhi@pengutronix.de>2021-08-24 16:21:01 +0200
committerArmin Kuster <akuster808@gmail.com>2021-08-25 07:16:32 -0700
commit323f33560c6207125739016253a34144b8e2b8fd (patch)
treec613625cf0f79bbe0a04247daad726cccffdcd1a
parentcef3e037ac534ddf1c6cd8020935cb379299d80b (diff)
downloadmeta-openembedded-323f33560c6207125739016253a34144b8e2b8fd.tar.gz
curlpp: fix override syntax
Commit bca3bbbf203086794e5b cherry-picked a fix from master, which used the new override syntax, which was introduced in poky commit 2abf8a699edd513405be (2021-07-25, "bitbake: bitbake: Switch to using new override syntax"). However, this change was merged after 3.4_M2 and is not part of hardknott, so bitbake complains about the new syntax: ERROR: ParseError at …/meta-openembedded/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb:20: unparsed line: 'do_install:append() {' Revert to the old syntax on the hardknott branch for now. Fixes: bca3bbbf203086794e5b (2021-08-09, "curlpp: fix QA Issue after LDFLAGS change") Signed-off-by: Roland Hieber <rhi@pengutronix.de> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
index 5df9238a67..bb1ee7d7ae 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -17,7 +17,7 @@ inherit cmake pkgconfig binconfig
BBCLASSEXTEND = "native nativesdk"
-do_install:append() {
+do_install_append() {
sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
-e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
-e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \