aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-05-19 13:35:12 -0700
committerArmin Kuster <akuster808@gmail.com>2022-06-03 06:59:23 -0700
commit9a2029553030f3da607c209b50581274e9e7335e (patch)
tree610cbe35f9f2eb93ac6f34c198672afc375b1e0c
parent16f08eb5aafc2851ab6a78fa72f2c2890a2d85d1 (diff)
downloadmeta-openembedded-9a2029553030f3da607c209b50581274e9e7335e.tar.gz
sdbus-c++: Link with libatomic on mips/ppc32
Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Gianfranco Costamagna <locutusofborg@debian.org> (cherry picked from commit 366663527aa5efd4e43a62919edcdf9caf14e77c) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
index 39f0b4c560..e1a7033a20 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
@@ -27,6 +27,11 @@ EXTRA_OECMAKE = "-DBUILD_CODE_GEN=OFF \
S = "${WORKDIR}/git"
+# Link libatomic on architectures without 64bit atomics fixes
+# libsdbus-c++.so.1.1.0: undefined reference to `__atomic_load_8'
+LDFLAGS:append:mips = " -Wl,--no-as-needed -latomic -Wl,--as-needed"
+LDFLAGS:append:powerpc = " -Wl,--no-as-needed -latomic -Wl,--as-needed"
+
do_install:append() {
if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
rm -rf ${D}${sysconfdir}/dbus-1