aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-05-17 09:10:20 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:39 -0700
commiteefd95829c3dfb77d264a2ee51fec36959e2d2b0 (patch)
treebbaf54ea0e818a0f1faff6530b8e2a77795bb15f
parent514157c01f33058fe7e7b05ffdaa4b872fd6399b (diff)
downloadmeta-openembedded-eefd95829c3dfb77d264a2ee51fec36959e2d2b0.tar.gz
x11vnc: remove old libtool macros from acinclude.m4
These can cause build problems. We only want macros in acinclude.m4 which aren't available for aclocal to get elsewhere. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit f6db87726d84976275cfe6b74a9e270f6bf6792e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
index 7e92965cc2..64c8a5d5d2 100644
--- a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
+++ b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
@@ -24,3 +24,9 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi',
PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi"
PACKAGECONFIG[xinerama] = "--with-xinerama,--without-xinerama,libxinerama"
PACKAGECONFIG[libvncserver] = "--with-system-libvncserver,--without-system-libvncserver,libvncserver"
+
+do_prepare_sources () {
+ # Remove old libtool macros from acinclude.m4
+ sed -i -e '/^# libtool.m4/q' acinclude.m4
+}
+do_patch[postfuncs] += "do_prepare_sources"