aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoris Offouga <offougajoris@gmail.com>2018-10-26 10:45:22 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-26 21:08:43 -0700
commit3ad039f79a48926e81522a6f0057885c56d32786 (patch)
treeeca091e0fb88d22eb6d9c2005ba049c2b1685fc0
parent18efa5fa25bcc6a8d6e28250518593d5ceaac060 (diff)
downloadmeta-openembedded-3ad039f79a48926e81522a6f0057885c56d32786.tar.gz
] Add recipes for django rest framework
Signed-off-by: Joris Offouga <offougajoris@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-djangorestframework.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-djangorestframework_3.9.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-djangorestframework.inc b/meta-python/recipes-devtools/python/python-djangorestframework.inc
new file mode 100644
index 0000000000..8551a8341d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-djangorestframework.inc
@@ -0,0 +1,16 @@
+SUMMARY = "djangorestframework"
+DESCRIPTION = "pip3 install djangorestframework"
+HOMEPAGE = "https://pypi.python.org/pypi/djangorestframework"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=7879a5a716147a784f7e524c9cf103c1"
+
+SRC_URI[md5sum] = "0d481bf8dbb87bb927b46798edc1a9bd"
+SRC_URI[sha256sum] = "607865b0bb1598b153793892101d881466bd5a991de12bd6229abb18b1c86136"
+PYPI_PACKAGE = "djangorestframework"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-django \
+" \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python-djangorestframework_3.9.0.bb b/meta-python/recipes-devtools/python/python-djangorestframework_3.9.0.bb
new file mode 100644
index 0000000000..540d12dc23
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-djangorestframework_3.9.0.bb
@@ -0,0 +1,2 @@
+require python-djangorestframework.inc
+inherit setuptools \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb b/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb
new file mode 100644
index 0000000000..9ed6d17266
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb
@@ -0,0 +1,2 @@
+require python-djangorestframework.inc
+inherit setuptools3 \ No newline at end of file