aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2018-11-05 00:59:15 -0500
committerArmin Kuster <akuster808@gmail.com>2018-11-15 13:18:51 -0800
commitcfe2b7d07ef26ffce123e14a9e2aa19254bc8bdd (patch)
tree54fc741ce50790cda626f4f0b50a48311c6acdd3
parent28893c142f5e7dcfc48b07fd4cdaac573618b24a (diff)
downloadmeta-openembedded-cfe2b7d07ef26ffce123e14a9e2aa19254bc8bdd.tar.gz
libunique: fix installed-vs-shipped qa issue
libunique shows installed-vs-shipped QA issue if configure option '--disable-introspection' is set by: 1) in gobject-introspection*.bbclass that the 'qemu-usermode' is not supported by bsp and then not set in MACHINE_FEATURES or: 2) set in local.conf directly: EXTRA_OECONF_append_pn-libunique = " --disable-introspection" Remove empty directory to fix the QA issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb b/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb
index 49ed07ad97..a6475cef6d 100644
--- a/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb
+++ b/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb
@@ -28,3 +28,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
inherit autotools pkgconfig gobject-introspection distro_features_check gtk-doc
REQUIRED_DISTRO_FEATURES = "x11"
+
+do_install_append () {
+ rmdir --ignore-fail-on-non-empty ${D}${datadir}
+}