aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2014-03-07 15:26:14 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-15 15:25:27 +0100
commit095fbd60d7b0b59558e49b97a20814d34626084e (patch)
treebb30f7221189bd4990c33c6e7e5217b5894f6467
parentc29189f45bdc7097f927b9f89d36f4bbad5ca67f (diff)
downloadmeta-openembedded-095fbd60d7b0b59558e49b97a20814d34626084e.tar.gz
vlan: Create 1.9 version
VLAN provides vconfig utility Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/vlan/vlan_1.9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
new file mode 100644
index 0000000000..2c4f1577e8
--- /dev/null
+++ b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
@@ -0,0 +1,25 @@
+SUMMARY = "VLAN provides vconfig utility"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://vconfig.c;md5=293ef69c4e88434d37a5ee577a5288cb"
+
+SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz"
+
+SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
+SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
+
+S = "${WORKDIR}/${BPN}"
+
+# comment out MakeInclude in Makefile which sets build environment
+do_configure_append () {
+ sed -i 's/^ include/#^include/' ${S}/Makefile
+}
+
+# ignore strip to avoid yocto errors in stripping
+do_compile () {
+ oe_runmake PLATFORM=ARM 'STRIP=echo' all
+}
+
+do_install () {
+ install -d ${D}/${exec_prefix}/bin
+ cp ${S}/vconfig ${D}/${exec_prefix}/bin
+}