aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 15:39:22 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-13 19:06:44 +0200
commit25a78e55e961197fd182afc8e21942bbbd8b4d59 (patch)
treef6fe164bc009248c476f98c350c1ab70297e90fe
parentd78c5215b35b945b0543b62234d00ae041de41b9 (diff)
downloadmeta-openembedded-25a78e55e961197fd182afc8e21942bbbd8b4d59.tar.gz
abiword, fbreader, tvheadend, glmark2, libqmi, modemmanager, thrift, wvdial, wvstreams, dt, collectd, gtkmathview, tcsh, glcompbench, geos, libspatialite, geis, grail, opencv, openwbem, fwts: blacklist, fails to build with gcc-6 or glibc-2.24
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb2
-rw-r--r--meta-gpe/recipes-support/fbreader/fbreader_0.12.10.bb3
-rw-r--r--meta-gpe/recipes-support/fbreader/fbreader_git.bb3
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb3
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb3
-rw-r--r--meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb3
-rw-r--r--meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb2
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb2
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb2
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb3
-rw-r--r--meta-oe/recipes-devtools/dt/dt_18.32.bb2
-rw-r--r--meta-oe/recipes-extended/collectd/collectd_5.5.0.bb3
-rw-r--r--meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb3
-rw-r--r--meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb3
-rw-r--r--meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb3
-rw-r--r--meta-oe/recipes-navigation/geos/geos_3.4.2.bb3
-rw-r--r--meta-oe/recipes-navigation/libspatialite/libspatialite_4.2.0.bb2
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb2
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/grail_3.1.0.bb3
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb2
-rw-r--r--meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb3
-rw-r--r--meta-oe/recipes-test/fwts/fwts_git.bb3
22 files changed, 58 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
index e0888c18fd..b413722593 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
@@ -122,3 +122,5 @@ python populate_packages_prepend () {
}
FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"
+
+PNBLACKLIST[abiword] ?= "Depends on broken gtkmathview"
diff --git a/meta-gpe/recipes-support/fbreader/fbreader_0.12.10.bb b/meta-gpe/recipes-support/fbreader/fbreader_0.12.10.bb
index 1487f11a2c..7a9de86e88 100644
--- a/meta-gpe/recipes-support/fbreader/fbreader_0.12.10.bb
+++ b/meta-gpe/recipes-support/fbreader/fbreader_0.12.10.bb
@@ -41,3 +41,6 @@ do_install() {
SRC_URI[md5sum] = "da9ec4721efdb0ec0aaa182bff16ad82"
SRC_URI[sha256sum] = "328aec454db80e225aa0b5c31adef74bf62a14357482947e87e9731686b3c624"
+
+# http://errors.yoctoproject.org/Errors/Details/68618/
+PNBLACKLIST[fbreader] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-gpe/recipes-support/fbreader/fbreader_git.bb b/meta-gpe/recipes-support/fbreader/fbreader_git.bb
index 763889a561..1ed65849a4 100644
--- a/meta-gpe/recipes-support/fbreader/fbreader_git.bb
+++ b/meta-gpe/recipes-support/fbreader/fbreader_git.bb
@@ -40,3 +40,6 @@ do_configure() {
do_install() {
oe_runmake install DESTDIR=${D} RESOLUTION=${READER_RESOLUTION}
}
+
+# http://errors.yoctoproject.org/Errors/Details/68618/
+PNBLACKLIST[fbreader] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
index 65d43c620d..2df85374a3 100644
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
@@ -29,3 +29,6 @@ do_install() {
}
FILES_${PN} += "${datadir}/${BPN}"
+
+# http://errors.yoctoproject.org/Errors/Details/68628/
+PNBLACKLIST[tvheadend] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index e29921b525..9c5ef1810d 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -50,3 +50,6 @@ python __anonymous() {
if flavors:
d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
}
+
+# http://errors.yoctoproject.org/Errors/Details/68626/
+PNBLACKLIST[glmark2] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb b/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb
index 7a15527f14..937fafc88f 100644
--- a/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb
+++ b/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb
@@ -14,3 +14,6 @@ inherit autotools pkgconfig
SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz"
SRC_URI[md5sum] = "24c9eb300662ba6cff0152de89bd9ec0"
SRC_URI[sha256sum] = "0857bffece4e8ddfa7f721dd9ca63b4c78de345ac9ae2faebf04062cacba3780"
+
+# http://errors.yoctoproject.org/Errors/Details/68616/
+PNBLACKLIST[libqmi] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb
index a173e696ab..00b85ffd5c 100644
--- a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb
+++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb
@@ -17,6 +17,8 @@ SRC_URI[sha256sum] = "7ef5035375a953b285a742591df0a65fd442f4641ce4d8f4392a41d6d6
S = "${WORKDIR}/ModemManager-${PV}"
+PNBLACKLIST[modemmanager] ?= "Depends on broken libqmi"
+
PACKAGECONFIG ??= "mbim qmi polkit \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
"
diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
index b6b73ade5d..e1413b0d5c 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
+++ b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
@@ -33,3 +33,5 @@ do_install_append () {
ln -sf thrift ${D}/${bindir}/thrift-compiler
}
+# http://errors.yoctoproject.org/Errors/Details/68622/
+PNBLACKLIST[thrift] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
index f7adf4c9f4..65617fa3be 100644
--- a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
@@ -28,3 +28,5 @@ do_configure() {
do_install() {
oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
}
+
+PNBLACKLIST[wvdial] ?= "Depends on broken wvstreams"
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
index 6199a2f7ec..8d864484ab 100644
--- a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
@@ -46,3 +46,6 @@ FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debu
FILES_${PN}-valgrind = "${libdir}/valgrind/wvstreams.supp"
RDEPENDS_${PN} += "perl"
+
+# http://errors.yoctoproject.org/Errors/Details/68614/
+PNBLACKLIST[wvstreams] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-devtools/dt/dt_18.32.bb b/meta-oe/recipes-devtools/dt/dt_18.32.bb
index 9688d02aac..d472fab8cc 100644
--- a/meta-oe/recipes-devtools/dt/dt_18.32.bb
+++ b/meta-oe/recipes-devtools/dt/dt_18.32.bb
@@ -45,3 +45,5 @@ do_install() {
}
RDEPENDS_${PN} += "tcsh"
+
+PNBLACKLIST[dt] ?= "Rdepends on broken tcsh"
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb b/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb
index 6a3476f540..b95f6e35fc 100644
--- a/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb
+++ b/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb
@@ -82,3 +82,6 @@ INITSCRIPT_PARAMS = "defaults"
# threshold.so load.so are also provided by gegl
# disk.so is also provided by libgphoto2-camlibs
PRIVATE_LIBS = "threshold.so load.so disk.so"
+
+# http://errors.yoctoproject.org/Errors/Details/68629/
+PNBLACKLIST[collectd] ?= "BROKEN: fails to build with glibc-2.24"
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb
index 3edbeed723..9c6af16cf7 100644
--- a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb
+++ b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb
@@ -21,3 +21,6 @@ do_configure_append() {
# avoid host polution inf pkg-config files
sed -i "s:${STAGING_DIR_HOST}::g" `find -name '*.pc'`
}
+
+# http://errors.yoctoproject.org/Errors/Details/68615/
+PNBLACKLIST[gtkmathview] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
index 1dd4cb5804..5a6f190617 100644
--- a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
+++ b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
@@ -47,3 +47,6 @@ pkg_postinst_${PN} () {
#!/bin/sh -e
echo /usr/bin/tcsh >> $D/etc/shells
}
+
+# http://errors.yoctoproject.org/Errors/Details/68619/
+PNBLACKLIST[tcsh] ?= "BROKEN: fails to build with glibc-2.24"
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
index d0f449438f..0c5d7b5fc3 100644
--- a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
+++ b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
@@ -14,3 +14,6 @@ SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b037
inherit pkgconfig waf distro_features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
+
+# http://errors.yoctoproject.org/Errors/Details/68631/
+PNBLACKLIST[glcompbench] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-navigation/geos/geos_3.4.2.bb b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb
index 3a9a028e8f..a0c43f3513 100644
--- a/meta-oe/recipes-navigation/geos/geos_3.4.2.bb
+++ b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb
@@ -4,3 +4,6 @@ SRC_URI += "file://geos-config-Add-includedir-variable.patch"
SRC_URI[md5sum] = "fc5df2d926eb7e67f988a43a92683bae"
SRC_URI[sha256sum] = "15e8bfdf7e29087a957b56ac543ea9a80321481cef4d4f63a7b268953ad26c53"
+
+# http://errors.yoctoproject.org/Errors/Details/68613/
+PNBLACKLIST[geos] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite_4.2.0.bb b/meta-oe/recipes-navigation/libspatialite/libspatialite_4.2.0.bb
index d66dc875be..fff195a0e7 100644
--- a/meta-oe/recipes-navigation/libspatialite/libspatialite_4.2.0.bb
+++ b/meta-oe/recipes-navigation/libspatialite/libspatialite_4.2.0.bb
@@ -21,3 +21,5 @@ SRC_URI[md5sum] = "83305ed694a77152120d1f74c5151779"
SRC_URI[sha256sum] = "9f138a6854740c7827fdee53845eb1485fce3e805a7aa9fc9151f8046ebd312d"
SRC_URI += "file://geos-config.patch"
+
+PNBLACKLIST[libspatialite] ?= "Depends on broken geos"
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
index bc88143ed6..f7898ba2c2 100644
--- a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
@@ -52,3 +52,5 @@ FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la"
FILES_${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a"
+
+PNBLACKLIST[geis] ?= "Depends on broken grail"
diff --git a/meta-oe/recipes-support/canonical-multitouch/grail_3.1.0.bb b/meta-oe/recipes-support/canonical-multitouch/grail_3.1.0.bb
index 6ea10d615c..6c8f295427 100644
--- a/meta-oe/recipes-support/canonical-multitouch/grail_3.1.0.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/grail_3.1.0.bb
@@ -21,3 +21,6 @@ PACKAGECONFIG[x11] = "--with-x11, --without-x11, libxi"
PACKAGE_BEFORE_PN += "${PN}-test"
FILES_${PN}-test = "${bindir}/grail-test*"
+
+# http://errors.yoctoproject.org/Errors/Details/68611/
+PNBLACKLIST[grail] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index 36876da2ca..c41baec7bb 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -146,3 +146,5 @@ do_install_append() {
cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/
}
+# http://errors.yoctoproject.org/Errors/Details/68617/
+PNBLACKLIST[opencv] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb
index ed8ef267c8..93cbdd7e36 100644
--- a/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb
+++ b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb
@@ -110,3 +110,6 @@ FILES_${PN}-dev = " \
${includedir} \
${datadir}/aclocal/openwbem.m4 \
"
+
+# http://errors.yoctoproject.org/Errors/Details/68630/
+PNBLACKLIST[openwbem] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-test/fwts/fwts_git.bb b/meta-oe/recipes-test/fwts/fwts_git.bb
index b943d6d48e..cad2ae0526 100644
--- a/meta-oe/recipes-test/fwts/fwts_git.bb
+++ b/meta-oe/recipes-test/fwts/fwts_git.bb
@@ -22,3 +22,6 @@ FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
FILES_${PN}-dbg += "${libdir}/fwts/.debug"
+
+# http://errors.yoctoproject.org/Errors/Details/68633/
+PNBLACKLIST[fwts] ?= "BROKEN: fails to build with gcc-6"