aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2017-11-08 13:10:27 +0100
committerArmin Kuster <akuster808@gmail.com>2017-11-19 13:41:58 -0800
commit2bbef0ce64608d09ff4510071931c8d6254d1123 (patch)
treef107824a7e53992c88a0889d95644f3d028e5668
parentf888426e9039111c6626c31415c00adfe5af7a9c (diff)
downloadmeta-openembedded-2bbef0ce64608d09ff4510071931c8d6254d1123.tar.gz
opencv: Fix java wrapper generation
During configuration the java wrappers are generated (if java is enabled via PACKAGECOFIG). Unfortunately, the script that generates the .java files do not handle properly paths with special symbols, such as +. This is just a workaround for that. Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv/javagen.patch16
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.3.bb1
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/javagen.patch b/meta-oe/recipes-support/opencv/opencv/javagen.patch
new file mode 100644
index 0000000000..56526ecd80
--- /dev/null
+++ b/meta-oe/recipes-support/opencv/opencv/javagen.patch
@@ -0,0 +1,16 @@
+Upstream-status: Inappropriate [OE specific] https://github.com/opencv/opencv/pull/10039#issuecomment-342539288
+
+Signed-off-by: Ricardo Ribalda <ricardo.ribalda@gmail.com>
+diff --git a/modules/java/CMakeLists.txt b/modules/java/CMakeLists.txt
+index 74bc0ef04169..4622fbf9a5f1 100644
+--- a/modules/java/CMakeLists.txt
++++ b/modules/java/CMakeLists.txt
+@@ -291,7 +291,7 @@ foreach(java_file ${step3_input_files})
+ endif()
+ if(__configure)
+ configure_file("${java_file}" "${java_src_dir}/${output_name}" @ONLY)
+- elseif(NOT "${java_file}" MATCHES "${OpenCV_BINARY_DIR}/")
++ elseif(EXISTS "${java_file}" AND NOT "${java_file}" MATCHES "${OpenCV_BINARY_DIR}/")
+ configure_file("${java_file}" "${java_src_dir}/${output_name}" COPYONLY)
+ else()
+ add_custom_command(OUTPUT "${java_src_dir}/${output_name}"
diff --git a/meta-oe/recipes-support/opencv/opencv_3.3.bb b/meta-oe/recipes-support/opencv/opencv_3.3.bb
index 8f0aa7f549..773bfe9f7a 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.3.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.3.bb
@@ -57,6 +57,7 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \
file://0001-carotene-don-t-use-__asm__-with-aarch64.patch \
file://0002-Do-not-enable-asm-with-clang.patch \
file://CVE-2017-14136.patch \
+ file://javagen.patch \
file://protobuf.patch \
"
PV = "3.3+git${SRCPV}"