aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-09-28 02:18:58 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-28 09:15:08 -0700
commit6cdaf5cc0681530eebc6405199e0aef0b33131a3 (patch)
treeb7985d0149b4a34310d4d92631cad2acb46b8067
parent6501ca786af77e7929237a80a9946f73c21e6730 (diff)
downloadmeta-openembedded-6cdaf5cc0681530eebc6405199e0aef0b33131a3.tar.gz
python3-cmd2: upgrade 2.1.2 -> 2.2.0
* Bug Fixes * Fixed extra space appended to each alias by "alias list" command * Enhancements * New function `set_default_ap_completer_type()` allows developer to extend and modify the behavior of `ArgparseCompleter`. * Added `ArgumentParser.get_ap_completer_type()` and `ArgumentParser.set_ap_completer_type()`. These methods allow developers to enable custom tab completion behavior for a given parser by using a custom `ArgparseCompleter`-based class. * Added `ap_completer_type` keyword arg to `Cmd2ArgumentParser.__init__()` which saves a call to `set_ap_completer_type()`. This keyword will also work with `add_parser()` when creating subcommands if the base command's parser is a `Cmd2ArgumentParser`. * New function `register_argparse_argument_parameter()` allows developers to specify custom parameters to be passed to the argparse parser's `add_argument()` method. These parameters will become accessible in the resulting argparse Action object when modifying `ArgparseCompleter` behavior. * Using `SimpleTable` in the output for the following commands to improve appearance. * help * set (command and tab completion of Settables) * alias tab completion * macro tab completion * Tab completion of `CompletionItems` now includes divider row comprised of `Cmd.ruler` character. * Removed `--verbose` flag from set command since descriptions always show now. * All cmd2 built-in commands now populate `self.last_result`. * Argparse tab completer will complete remaining flag names if there are no more positionals to complete. * Updated `async_alert()` to account for `self.prompt` not matching Readline's current prompt. * Deletions (potentially breaking changes) * Deleted ``set_choices_provider()`` and ``set_completer()`` which were deprecated in 2.1.2 Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb)3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb b/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
index 874e7cf0c1..2632ce1c80 100644
--- a/meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4c527bcb481233ebcb803de975f42701"
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-SRC_URI[sha256sum] = "25dbb2e9847aaa686a8a21e84e3d101db8b79f5cb992e044fc54210ab8c0ad41"
+SRC_URI[sha256sum] = "34cd12424d9e2835eff125146af3d9f4a4c2931c6bc5a3cea9790bd4f55756d9"
inherit pypi setuptools3
@@ -17,6 +17,7 @@ RDEPENDS:${PN} += "\
${PYTHON_PN}-compression \
${PYTHON_PN}-pydoc \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-numbers \
"
BBCLASSEXTEND = "native nativesdk"