aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-12 23:11:01 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-14 07:15:37 -0700
commitbf9c1d7b2e0f1fd3345c69a5d352a3fe2f86262f (patch)
tree3b0b5cd6d2b618c5bf5b6b1a03d553bc5402b945
parent55534f9d10210120d47ad18526fadf77a752a83c (diff)
downloadmeta-openembedded-bf9c1d7b2e0f1fd3345c69a5d352a3fe2f86262f.tar.gz
python3-simpleeval: Remove use_2to3
package works with py2 and py3, there is no need to use 2to3 See https://github.com/jobsta/simpleeval/commit/4ea1a5d15d449ab805bae042a698b381ddefd5b1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb
index 9708fc6262..36512cba9a 100644
--- a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb
+++ b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb
@@ -17,7 +17,9 @@ SRC_URI += " \
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
-
+do_configure:prepend() {
+ sed -i -e "/use_2to3=True,/d" ${S}/setup.py
+}
do_install_ptest() {
cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/
}