aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-11-27 16:44:17 -0200
committerKhem Raj <raj.khem@gmail.com>2018-11-28 21:48:21 -0800
commitcce5af60b15a1d273ba6497cd5222cec2ad8b1fa (patch)
treebcf3c326b8c410ca403b4e1c208c15de37db0cb9
parent12ea320bdba56a7827931d731e9edb2f5ea7e09b (diff)
downloadmeta-openembedded-cce5af60b15a1d273ba6497cd5222cec2ad8b1fa.tar.gz
mozjs: Avoid use of X11 from host when X11 is disabled
The mozjs build system makes use of host headers and libraries if not passed an invalid path for `--x-includes` and `--x-libraries`. This fixes host contamination while building in a development host. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
index 0dfe2f8484..440a25b74e 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
@@ -49,7 +49,7 @@ EXTRA_OECONF = " \
"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
-PACKAGECONFIG[x11] = "--x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},,virtual/libx11"
+PACKAGECONFIG[x11] = "--x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--x-includes=no --x-libraries=no,virtual/libx11"
EXTRA_OEMAKE_task-compile += "OS_LDFLAGS='-Wl,-latomic ${LDFLAGS}'"
EXTRA_OEMAKE_task-install += "STATIC_LIBRARY_NAME=js_static"