aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2021-04-29 02:24:27 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-29 09:02:39 -0700
commitd8b046900c85047df05fb234d7e7b673f5c14c19 (patch)
tree5022de388d8b7fb73ae08540a3dc4a5264f9f9aa
parent3e4081db294fe67529ab9face088bda77100d2b1 (diff)
downloadmeta-openembedded-d8b046900c85047df05fb234d7e7b673f5c14c19.tar.gz
tigervnc: fix do_package error when enabling user merge
When enabling user merge, we get the following error: ERROR: QA Issue: tigervnc: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/vncserver@.service Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb b/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb
index ce6c59bc39..c45fc028fc 100644
--- a/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb
+++ b/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb
@@ -83,7 +83,7 @@ EXTRA_OECONF = "--disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
--disable-xwayland \
"
-EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DCMAKE_INSTALL_UNITDIR=/lib/systemd/system', '-DINSTALL_SYSTEMD_UNITS=OFF', d)}"
+EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DCMAKE_INSTALL_UNITDIR=${systemd_unitdir}', '-DINSTALL_SYSTEMD_UNITS=OFF', d)}"
do_configure_append () {
olddir=`pwd`