aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:18:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:02 +0200
commit48442f26214e67567321e9091f2c43f745cfe980 (patch)
treed2e0534b16f7f67e08c3e426367965047d36d786 /meta-efl
parent7baa466291ecdce5d36fb6cfa17689d2419549ba (diff)
downloadmeta-openembedded-48442f26214e67567321e9091f2c43f745cfe980.tar.gz
entrance: move systemd support from meta-systemd back to meta-efl
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/efl/entrance/entrance.service8
-rw-r--r--meta-efl/recipes-efl/efl/entrance_svn.bb19
2 files changed, 26 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/efl/entrance/entrance.service b/meta-efl/recipes-efl/efl/entrance/entrance.service
new file mode 100644
index 0000000000..4828686952
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/entrance/entrance.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Login manager for Enlightenment
+
+[Service]
+ExecStart=/usr/sbin/entrance
+
+[Install]
+Alias=display-manager.service
diff --git a/meta-efl/recipes-efl/efl/entrance_svn.bb b/meta-efl/recipes-efl/efl/entrance_svn.bb
index 585d552c2c..02eb64ba91 100644
--- a/meta-efl/recipes-efl/efl/entrance_svn.bb
+++ b/meta-efl/recipes-efl/efl/entrance_svn.bb
@@ -4,18 +4,35 @@ LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
SECTION = "e/apps"
-inherit e gettext
+inherit e gettext systemd
SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};protocol=http;scmdata=keep \
file://0001-pam-use-common-auth-instead-of-system-auth.patch \
+ file://entrance.service \
"
S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc ${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-pam', d)}"
+PR = "r4"
PV = "0.0.4+svnr${SRCPV}"
SRCREV = "${EFL_SRCREV}"
RDEPENDS_${PN} += "${PN}-themes sessreg xauth"
CONFFILES_${PN} += "${sysconfdir}/entrance.conf"
+
RCONFLICTS_${PN} += "xserver-nodm-init"
RREPLACES_${PN} += "xserver-nodm-init"
+
+RCONFLICTS_${PN} += "xserver-nodm-init-systemd"
+RREPLACES_${PN} += "xserver-nodm-init-systemd"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+
+SYSTEMD_SERVICE_${PN} = "entrance.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/entrance.service ${D}${systemd_unitdir}/system
+}