aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-30 13:10:07 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-05 10:05:03 +0200
commit605e8f47b2ace1f6c7cb44aef463de10d9f41edd (patch)
treec8a62e5594707860cbcbb5cdaa94ad42ac4cd3f6 /meta-efl
parent945134094d2e6bab0978c81c1784c20c185ba842 (diff)
downloadmeta-openembedded-605e8f47b2ace1f6c7cb44aef463de10d9f41edd.tar.gz
terminology: add version 0.1.0, negative D_P to svn and bump PE
* PE bump is needed for upgrade path from svn recipe to 0.1.0 release Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/conf/distro/include/efl-from-svn-recipes.inc2
-rw-r--r--meta-efl/recipes-efl/e17/terminology.inc23
-rw-r--r--meta-efl/recipes-efl/e17/terminology_0.1.0.bb10
-rw-r--r--meta-efl/recipes-efl/e17/terminology_svn.bb22
4 files changed, 38 insertions, 19 deletions
diff --git a/meta-efl/conf/distro/include/efl-from-svn-recipes.inc b/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
index b017645964..c28e281fbd 100644
--- a/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
+++ b/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
@@ -37,3 +37,5 @@ PREFERRED_VERSION_python-edbus ?= "${EFL_PYTHON_PREFERRED_VERSION}"
PREFERRED_VERSION_python-edje ?= "${EFL_PYTHON_PREFERRED_VERSION}"
PREFERRED_VERSION_python-emotion ?= "${EFL_PYTHON_PREFERRED_VERSION}"
PREFERRED_VERSION_python-evas ?= "${EFL_PYTHON_PREFERRED_VERSION}"
+
+PREFERRED_VERSION_terminology ?= "0.1.0+svn%"
diff --git a/meta-efl/recipes-efl/e17/terminology.inc b/meta-efl/recipes-efl/e17/terminology.inc
new file mode 100644
index 0000000000..15af6ea50e
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/terminology.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "Enlightenment Terminal Emulator"
+LICENSE = "MIT BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03f6c2cf2bef233fadf7d0769f5bfda7"
+DEPENDS = "evas ecore edje elementary eina eet emotion"
+
+inherit e gettext
+INC_PR = "r2"
+
+# Because latest release we have is 0.1.0 which sorts lower then 0.1.0+svnr${SRCPV} already in feeds
+PE = "2"
+
+EXTRA_OECONF = "\
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+"
+
+FILES_${PN} += "\
+ ${datadir}/icons/terminology.png \
+"
+
+# doesn't start without own theme
+# ERR<770>:terminology utils.c:26 theme_apply() Could not load any theme for group=terminology/background: No Error
+# CRI<770>:terminology main.c:448 elm_main() Couldn't find terminology theme! Forgot 'make install'?
+RDEPENDS_${PN} += "${PN}-themes"
diff --git a/meta-efl/recipes-efl/e17/terminology_0.1.0.bb b/meta-efl/recipes-efl/e17/terminology_0.1.0.bb
new file mode 100644
index 0000000000..7a04069dbb
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/terminology_0.1.0.bb
@@ -0,0 +1,10 @@
+require ${BPN}.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "\
+ ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
+"
+
+SRC_URI[md5sum] = "30867692e44799cd9bbe6562d69ae62d"
+SRC_URI[sha256sum] = "87f32089b2731c3e9a72b5bde92695eb91097fa79dbb70388774c9dcb5442ebb"
diff --git a/meta-efl/recipes-efl/e17/terminology_svn.bb b/meta-efl/recipes-efl/e17/terminology_svn.bb
index 48d229b4e7..9fa1304120 100644
--- a/meta-efl/recipes-efl/e17/terminology_svn.bb
+++ b/meta-efl/recipes-efl/e17/terminology_svn.bb
@@ -1,25 +1,9 @@
-DESCRIPTION = "Enlightenment Terminal Emulator"
-LICENSE = "MIT BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=03f6c2cf2bef233fadf7d0769f5bfda7"
-DEPENDS = "evas ecore edje elementary eina eet emotion"
+require ${BPN}.inc
+DEFAULT_PREFERENCE = "-1"
PV = "0.1.0+svnr${SRCPV}"
-PR = "r1"
+PR = "${INC_PR}.0"
SRCREV = "${EFL_SRCREV}"
-inherit e gettext
SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep"
S = "${WORKDIR}/${SRCNAME}"
-
-EXTRA_OECONF = "\
- --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
-"
-
-FILES_${PN} += "\
- ${datadir}/icons/terminology.png \
-"
-
-# doesn't start without own theme
-# ERR<770>:terminology utils.c:26 theme_apply() Could not load any theme for group=terminology/background: No Error
-# CRI<770>:terminology main.c:448 elm_main() Couldn't find terminology theme! Forgot 'make install'?
-RDEPENDS_${PN} += "${PN}-themes"