aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:37:00 +0100
committerArmin Kuster <akuster808@gmail.com>2016-04-17 13:06:14 -0700
commitbdff28d9a7863494b2a41f54de4e3fe0a7e29470 (patch)
treef35f1a117f1f7bd0efcbccc6d5910a1491597b66 /meta-efl
parent9a0ee11cfbfcc831902ba8c57d9aad8169c88c9e (diff)
downloadmeta-openembedded-bdff28d9a7863494b2a41f54de4e3fe0a7e29470.tar.gz
recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode,links"
* Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html Dropped Lua patch as no ptest support exists in jethro Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Conflicts: meta-oe/recipes-devtools/lua/lua_5.3.1.bb
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
index 1d8098f60d..3e72261e22 100644
--- a/meta-efl/recipes-devtools/python/python-edbus.inc
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -39,7 +39,7 @@ do_install_append() {
done
cd ${S}
install -d ${D}${datadir}/${PN}/
- cp -a examples ${D}${datadir}/${PN}/
+ cp -R --no-dereference --preserve=mode,links -v examples ${D}${datadir}/${PN}/
find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
fi
}