aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2017-07-13 22:59:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:57:33 +0200
commit00eacac42f3b676022d6a0585bb9b375f8da3f06 (patch)
tree7d631a92dd3bc30f36781727a4e195fe5d1e8d96 /meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb
parenta246dd26a5af8f9b23a98756ce0bcfc21d91a17e (diff)
downloadmeta-openembedded-00eacac42f3b676022d6a0585bb9b375f8da3f06.tar.gz
recipes-utils: Add recipe for udevil
udevil is a command line Linux program which mounts and unmounts removable devices without a password. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb')
-rw-r--r--meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb b/meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb
new file mode 100644
index 0000000000..c432e85468
--- /dev/null
+++ b/meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb
@@ -0,0 +1,28 @@
+SUMMARY = "A command line Linux program which mounts and unmounts removable devices"
+HOMEPAGE = "http://ignorantguru.github.io/udevil/"
+
+DEPENDS = "glib-2.0 \
+ glib-2.0-native \
+ intltool-native \
+ udev \
+"
+RDEPENDS_${PN} = "udev"
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+inherit autotools systemd
+
+SRC_URI = "https://github.com/IgnorantGuru/udevil/raw/pkg/${PV}/udevil-${PV}.tar.xz \
+ file://0001-udevil-0.4.3-fix-compile-with-gcc6.patch \
+ file://0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch \
+"
+
+SRC_URI[md5sum] = "dc1c489b603a0500a04dc7e1805ac1d9"
+SRC_URI[sha256sum] = "ce8c51fd4d589cda7be56e75b42188deeb258c66fc911a9b3a70a3945c157739"
+
+PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
+PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
+
+SYSTEMD_SERVICE_${PN} = "devmon@.service"
+SYSTEMD_AUTO_ENABLE = "disable"