aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2022-08-12 15:56:28 +0800
committerKhem Raj <raj.khem@gmail.com>2022-08-12 01:24:27 -0700
commit4785cc2cd3bcb5635f8942f49f21d0e16edd3f09 (patch)
tree9a8dbdec6ac9231d154a5183438e5b03d071475e /meta-filesystems
parent015fcc40539995eccd62eed11c67598be4bd0d81 (diff)
downloadmeta-openembedded-4785cc2cd3bcb5635f8942f49f21d0e16edd3f09.tar.gz
fuse3: support ptest
fuse3 test is designed to run under source dir, there are many places like "progname = pjoin(basename, 'example', 'ioctl')" in the testcases, which will try to find compiled program. As our S != B, and the don't run test under source dir. Test will fail with following errors: No such file or directory: '/usr/lib64/fuse3/ptest/test/../example/printcap' Fix by install needed programs for the test Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3_3.11.0.bb25
1 files changed, 21 insertions, 4 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse3_3.11.0.bb b/meta-filesystems/recipes-support/fuse/fuse3_3.11.0.bb
index 0b9164fd79..8055fb06d3 100644
--- a/meta-filesystems/recipes-support/fuse/fuse3_3.11.0.bb
+++ b/meta-filesystems/recipes-support/fuse/fuse3_3.11.0.bb
@@ -35,7 +35,28 @@ RDEPENDS:${PN}-ptest += " \
do_install_ptest() {
install -d ${D}${PTEST_PATH}/test
+ install -d ${D}${PTEST_PATH}/example
+ install -d ${D}${PTEST_PATH}/util
cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
+
+ example_excutables=`find ${B}/example -type f -executable`
+ util_excutables=`find ${B}/util -type f -executable`
+ test_excutables=`find ${B}/test -type f -executable`
+
+ for e in $example_excutables
+ do
+ cp -rf $e ${D}${PTEST_PATH}/example/
+ done
+
+ for e in $util_excutables
+ do
+ cp -rf $e ${D}${PTEST_PATH}/util/
+ done
+
+ for e in $test_excutables
+ do
+ cp -rf $e ${D}${PTEST_PATH}/test
+ done
}
DEPENDS = "udev"
@@ -49,10 +70,6 @@ RRECOMMENDS:${PN}:class-target = "kernel-module-fuse fuse3-utils"
FILES:${PN} += "${libdir}/libfuse3.so.*"
FILES:${PN}-dev += "${libdir}/libfuse3*.la"
-EXTRA_OEMESON += " \
- -Dexamples=false \
-"
-
# Forbid auto-renaming to libfuse3-utils
FILES:fuse3-utils = "${bindir} ${base_sbindir}"
DEBIAN_NOAUTONAME:fuse3-utils = "1"