aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-10 12:52:09 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-10 09:13:40 -0800
commit795536641f3958e20622bbf179b211da9ecc860e (patch)
tree4faa7050adbaa8c26963010e8db7421422e31614 /meta-filesystems
parent405ee461078cfed493bd6ca06f922860be5081d0 (diff)
downloadmeta-openembedded-795536641f3958e20622bbf179b211da9ecc860e.tar.gz
bindfs: add recipe
Add bindfs, a FUSE filesystem for mounting a directory to another location, similarly to mount --bind. The permissions inside the mountpoint can be altered using various rules. Version 1.17.5: - Support negative --{uid,gid}-offset - Support mount -t bindfs on Mac OS This work was sponsored by GOVCERT.LU. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/binfs/bindfs_1.17.5.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/binfs/bindfs_1.17.5.bb b/meta-filesystems/recipes-utils/binfs/bindfs_1.17.5.bb
new file mode 100644
index 0000000000..c701e223e9
--- /dev/null
+++ b/meta-filesystems/recipes-utils/binfs/bindfs_1.17.5.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A FUSE filesystem for mounting a directory to another location"
+DESCRIPTION = "bindfs is a FUSE filesystem for mounting a directory to another location, similarly to mount --bind."
+HOMEPAGE = "https://bindfs.org/"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "fuse"
+RDEPENDS:${PN} = "fuse"
+
+SRC_URI = "git://github.com/mpartel/bindfs;protocol=https;branch=master"
+SRCREV = "3f57fa69448ad68f31cf62cf75b5a9b2e5096c05"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig gettext