aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2023-09-30 00:26:59 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-30 01:03:17 -0700
commitc63a101cf99ebf2af265c073509fa45d8d71c525 (patch)
tree313a5b64e6fddbe19734cbc650c0e73d144ecf85 /meta-filesystems
parentae8faf852988cfed875e8bc73c911b89f3d052ad (diff)
downloadmeta-openembedded-c63a101cf99ebf2af265c073509fa45d8d71c525.tar.gz
overlayfs-tools: Install fsck binary
Two projects, overlayfs-tools and overlayfs-progs, were combined upstream. Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch32
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb32
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb5
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb2
4 files changed, 2 insertions, 69 deletions
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch
deleted file mode 100644
index 2c001834b6..0000000000
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 8eeaee82dcfdf47f16ad880e416b722827f41bdb Mon Sep 17 00:00:00 2001
-From: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
-Date: Mon, 23 May 2022 19:37:32 +0200
-Subject: [PATCH] Makefile: proper location of LDFLAGS
-
-Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
----
-Upstream-Status: Pending
-
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index e3c5207..14b155e 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,5 +1,5 @@
- CFLAGS = -Wall -g
--LFLAGS = -lm
-+LDFLAGS = -lm
- CC = gcc
-
- all: overlay
-@@ -7,7 +7,7 @@ all: overlay
- objects = fsck.o common.o lib.o check.o mount.o path.o overlayfs.o
-
- overlay: $(objects)
-- $(CC) $(LFLAGS) $(objects) -o fsck.overlay
-+ $(CC) $(objects) -o fsck.overlay $(LDFLAGS)
-
- .c.o:
- $(CC) $(CFLAGS) -c $<
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb
deleted file mode 100644
index 9d58b9a63f..0000000000
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-SUMMARY = "File system check utility for OverlayFS"
-HOMEPAGE = "https://github.com/hisilicon/overlayfs-progs"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
-
-SRC_URI = "\
- git://github.com/hisilicon/overlayfs-progs.git;protocol=https;branch=master \
- file://0001-Makefile-proper-location-of-LDFLAGS.patch \
-"
-
-PV = "1.0+git${SRCPV}"
-SRCREV = "e10ef686570d9c7eff42f52461593a5c15da56bd"
-
-S = "${WORKDIR}/git"
-B = "${S}"
-
-# Required to have the fts.h header for musl
-DEPENDS:append:libc-musl = " fts"
-# Fix the missing fts libs when using musl
-EXTRA_OEMAKE:append:libc-musl = " LDFLAGS='-lfts'"
-
-EXTRA_OEMAKE += "'CC=${CC} -O2' "
-TARGET_CC_ARCH += "${LDFLAGS}"
-
-do_compile () {
- oe_runmake
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 ${B}/fsck.overlay ${D}${bindir}
-}
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
index de51551337..ca2ec9cc4f 100644
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
+++ b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
@@ -21,11 +21,8 @@ EXTRA_OEMAKE += "'CC=${CC} -O2'"
EXTRA_OEMAKE:append:libc-musl = " LDLIBS=-lfts"
TARGET_CC_ARCH += "${LDFLAGS}"
-do_compile () {
- oe_runmake
-}
-
do_install () {
install -d ${D}${bindir}
install -m 0755 ${B}/overlay ${D}${bindir}
+ install -m 0755 ${B}/fsck.overlay ${D}${bindir}
}
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb
index fdfe045749..cfb6e4fd82 100644
--- a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb
@@ -28,7 +28,7 @@ RDEPENDS:${PN} += "\
e2fsprogs-resize2fs \
libaio \
libcap-bin \
- overlayfs-progs \
+ overlayfs-tools \
perl \
python3 \
python3-core \