aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorAngelo.Ribeiro <Angelo.Ribeiro@criticaltechworks.com>2024-02-05 10:01:05 +0000
committerKhem Raj <raj.khem@gmail.com>2024-02-09 09:52:06 -0800
commite73a360455a986d6e0ab86472810d23e3a34b414 (patch)
tree1537d26a81c5b41a7cf411d7ef967aa47d69638d /meta-filesystems
parent184e1a4469bd5eee153fd43fc8a5a80433ff2592 (diff)
downloadmeta-openembedded-e73a360455a986d6e0ab86472810d23e3a34b414.tar.gz
e2tools: Add tool recipe
e2tools is a simple set of GPL'ed utilities to read, write, and manipulate files in an ext2/ext3 filesystem. These utilities access a filesystem directly using the ext2fs library. Signed-off-by: Angelo.Ribeiro <Angelo.Ribeiro@criticaltechworks.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/e2tools/e2tools_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb b/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb
new file mode 100644
index 0000000000..caf0025c8e
--- /dev/null
+++ b/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Set of GPL'ed utilities to ext2/ext3 filesystem."
+DESCRIPTION = "e2tools is a simple set of GPL'ed utilities to read, write, \
+and manipulate files in an ext2/ext3 filesystem. These utilities access a \
+filesystem directly using the ext2fs library. Can also be used on a Linux \
+machine to read/write to disk images or floppies without having to mount \
+them or have root access."
+HOMEPAGE = "https://github.com/e2tools/e2tools"
+SECTION = "base"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS += "e2fsprogs"
+
+PV = "0.1.0+git"
+
+SRC_URI = " \
+ git://github.com/e2tools/e2tools;protocol=https;branch=master \
+"
+SRCREV = "fd092754a6b65c3a769f74f888668c066f09c36d"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND = "native"