aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-06-26 04:34:00 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:25 +0200
commit750695c35426532201d1c802460ccf7ab5baddd1 (patch)
tree0fa92d9d82d6c302b2a0aef8b93e7dcb0e7ef52c /meta-filesystems
parentec9f60a6ef6e4434705756511aa76fc4ee6e4f1d (diff)
downloadmeta-openembedded-750695c35426532201d1c802460ccf7ab5baddd1.tar.gz
xfsprogs: remove redundant install rule in do_install
Since the recipe inherits autotools-brokensep, it has `make install' in do_install by default. The extra one is not required which may conflict with install-dev. Occasionally build failure: ... Installing include-install Installing libxfs-install-dev make[1]: *** No rule to make target '../inclu', needed by 'xfs_dir2.lo'. Stop. make[1]: *** Waiting for unfinished jobs.... make: *** [Makefile:132: libxfs-install-dev] Error 2 ... It is hard to reproduce by manual build, so export BUILD_VERBOSE to gain more debug info duiring the build. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb
index 50ab9872e7..b4f2c1186b 100644
--- a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb
+++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb
@@ -41,6 +41,7 @@ PACKAGECONFIG[readline] = "--enable-readline=yes,--enable-readline=no,readline"
PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux"
export DEBUG="-DNDEBUG"
+export BUILD_VERBOSE="1"
EXTRA_OEMAKE = "DIST_ROOT='${D}'"
@@ -54,7 +55,7 @@ do_configure_prepend () {
}
do_install_append() {
- oe_runmake 'DESTDIR=${D}' install install-dev
+ oe_runmake 'DESTDIR=${D}' install-dev
rm ${D}${libdir}/*.la
rmdir --ignore-fail-on-non-empty ${D}${libdir}
}