aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/abiword
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-04-21 20:09:00 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-04-21 20:09:13 +0200
commitdcb014c8fab65e9dd15c97904395ac46d8451419 (patch)
tree49d8bf85782328007ab5d902fd9eae41d71c028b /meta-gnome/recipes-gnome/abiword
parent111a652bb6631045720bab2947fd798f95bac176 (diff)
downloadmeta-openembedded-dcb014c8fab65e9dd15c97904395ac46d8451419.tar.gz
abiword*: import from oe-core rev 0a6f77f549c095692045825f4b5c4c5a2edff73c
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword-2.5.inc63
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb12
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword.inc63
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb5
4 files changed, 143 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword-2.5.inc b/meta-gnome/recipes-gnome/abiword/abiword-2.5.inc
new file mode 100644
index 0000000000..e3f6a9d2b9
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword-2.5.inc
@@ -0,0 +1,63 @@
+DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2"
+RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+
+#want 2.x from 2.x.y for the installation directory
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+FILES_${PN} += " \
+ ${datadir}/icons/* \
+ ${datadir}/abiword-${SHRT_VER}/glade \
+ ${datadir}/abiword-${SHRT_VER}/scripts \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en_GB \
+# ${datadir}/abiword-${SHRT_VER}/templates/A4.awt \
+# ${datadir}/abiword-${SHRT_VER}/templates/US-Letter.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
+ ${datadir}/abiword-${SHRT_VER}/templates/Employee-Directory.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Business-Report.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Fax-Coversheet.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Resume.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Two-Columns.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt "
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --disable-pspell \
+ --disable-spellcheck \
+ --disable-printing \
+ --disable-exports \
+ --with-sys-wv"
+
+# AbiWord configure.ac does not play nicely with autoreconf
+# so use the autogen.sh script that comes with AbiWord
+#
+do_configure() {
+ cd ${S}
+ export NOCONFIGURE="no"; ./autogen.sh
+ oe_runconf
+}
+
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
+
+FILES_abiword-clipart += "${datadir}/abiword-${SHRT_VER}/clipart"
+FILES_abiword-icons += "${datadir}/abiword-${SHRT_VER}/icons"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/AbiWord/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/AbiWord/system.profile*"
+FILES_abiword-templates += "${datadir}/abiword-${SHRT_VER}/templates"
diff --git a/meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb b/meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb
new file mode 100644
index 0000000000..7ee0f866a0
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb
@@ -0,0 +1,12 @@
+require abiword-2.5.inc
+
+PR = "r1"
+
+EXTRA_OECONF += "--enable-embedded"
+
+S = "${WORKDIR}/abiword-${PV}"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
+
+
diff --git a/meta-gnome/recipes-gnome/abiword/abiword.inc b/meta-gnome/recipes-gnome/abiword/abiword.inc
new file mode 100644
index 0000000000..5d7e3ce600
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword.inc
@@ -0,0 +1,63 @@
+DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
+SECTION = "gnome/office"
+HOMEPAGE = "http://www.abiword.org""
+LICENSE = "GPLv2"
+
+DEPENDS = "libgsf libglade libfribidi libxml2 wv"
+RRECOMMENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+
+# Share this file between recipes that use cvs and that pull tarballs
+# (one day change this to differentiate automatically based on PV and set the
+# SRC_URI and S var directly)
+RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+RELSRC = "${WORKDIR}/abiword-${PV}/abi"
+
+CVSURI = "cvs://anoncvs:anoncvs@anoncvs.abisource.com/cvsroot;module=abi"
+CVSSRC = "${WORKDIR}/abi"
+
+#want 2.x from 2.x.y for the installation directory
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+FILES_${PN} += " \
+ ${datadir}/icons/* \
+ ${datadir}/mime-info \
+ ${datadir}/abiword-${SHRT_VER}/glade \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
+# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
+# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
+ "
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+# This is a minimalistic AbiWord build
+#
+# if you are planning to build plugins, make sure to comment out the
+# --disable-exports options
+
+EXTRA_OECONF = " --enable-embedded=poky \
+ --disable-printing \
+ --with-sys-wv \
+ --disable-exports \
+ --disable-spellcheck"
+
+# TODO -- refactor this, so that instead of two strings and profiles
+# packages we have lots of locale packages, each with a set of strings and
+# a profile
+#
+PACKAGES += " abiword-strings abiword-systemprofiles"
+
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+
+# AbiWord configure.ac does not play nicely with autoreconf
+# so use the autogen.sh script that comes with AbiWord
+#
+do_configure() {
+ cd ${S}
+ export NOCONFIGURE="no"; ./autogen.sh
+ oe_runconf
+}
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb
new file mode 100644
index 0000000000..c10d761b06
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb
@@ -0,0 +1,5 @@
+require abiword-2.5.inc
+
+PR = "r2"
+
+RCONFLICTS_${PN} = "abiword-embedded"