aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/evince
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmx.de>2011-10-30 19:33:44 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-31 11:45:33 +0100
commitf3585ea14677b1be474cf6f215f870845a4e91cb (patch)
tree41fb39426e940a6a2541122fac6f4e47c0eaaffb /meta-gnome/recipes-gnome/evince
parent883af4db628412acd204a2ff85804c47d6447ede (diff)
downloadmeta-openembedded-f3585ea14677b1be474cf6f215f870845a4e91cb.tar.gz
evince: initial add 2.32.0
* recipe based on oe-classic: evince_2.30.0.bb commit 5dba154457691d2096f2b1a7ef24bdc6f1b51859 * run tested on overo * TODO further doctype support configure option -> current configure result ------------------------------------------------ --enable-ps -> PostScript Backend.: no --enable-djvu -> DJVU Backend.......: no --enable-impress -> Impress Backend....: no Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/evince')
-rw-r--r--meta-gnome/recipes-gnome/evince/evince_2.32.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/evince/evince_2.32.0.bb b/meta-gnome/recipes-gnome/evince/evince_2.32.0.bb
new file mode 100644
index 0000000000..899d416ee7
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evince/evince_2.32.0.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Evince is a document viewer for document formats like pdf, ps, djvu."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b"
+SECTION = "x11/office"
+DEPENDS = "gnome-icon-theme gnome-doc-utils-native libgnome-keyring nautilus tiff libxt ghostscript poppler libxml2 gtk+ gconf libglade"
+
+inherit gnome pkgconfig gtk-icon-cache
+
+SRC_URI[archive.md5sum] = "ebc3ce6df8dcbf29cb9492f8dd031319"
+SRC_URI[archive.sha256sum] = "2a4c91ae38f8b5028cebb91b9da9ddc50ea8ae3f3d429df89ba351da2d787ff7"
+
+EXTRA_OECONF = " --enable-thumbnailer \
+ --enable-nautilus \
+ --disable-scrollkeeper \
+ --enable-pixbuf \
+ "
+
+do_install_append() {
+ install -d install -d ${D}${datadir}/pixmaps
+ install -m 0755 ${S}/data/icons/48x48/apps/evince.png ${D}${datadir}/pixmaps/
+}
+
+RDEPENDS_${PN} += "glib-2.0-utils"
+
+PACKAGES =+ "${PN}-nautilus-extension"
+FILES_${PN} += "${datadir}/dbus-1"
+FILES_${PN}-dbg += "${libdir}/*/*/.debug \
+ ${libdir}/*/*/*/.debug"
+FILES_${PN}-dev += "${libdir}/nautilus/extensions-2.0/*.la"
+FILES_${PN}-staticdev += "${libdir}/nautilus/extensions-2.0/*.a"
+FILES_${PN}-nautilus-extension = "${libdir}/nautilus/*/*so"
+
+pkg_postinst_${PN} () {
+if [ -n "$D" ]; then
+ exit 1
+fi
+
+glib-compile-schemas ${datadir}/glib-2.0/schemas
+}