aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-05-08 09:57:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-05-08 10:20:16 +0200
commit7e5b1e477a25c3dc661a2c155a22022a07903d0a (patch)
treec1150804bf0d9811cc3778c541529641b1be8dd9 /meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
parenteaafb0b441e9645cad3e1a7a6730be4b19c65d54 (diff)
downloadmeta-openembedded-7e5b1e477a25c3dc661a2c155a22022a07903d0a.tar.gz
orbit2: cleanup recipe, merge .inc and -native
* fix LICENSE field * this also upgrades -native from 2.14.12 to 2.14.17, because 2.14.12 is failing to configure:13143: checking alignment of CORBA_octet configure:13170: gcc -o conftest -isystem/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include -O2 -pipe -isystem/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include -pthread -I/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include/glib-2.0 -I/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib/glib-2.0/include -L/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib -L/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/lib -Wl,-rpath-link,/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib -Wl,-rpath-link,/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/lib -Wl,-rpath,/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib -Wl,-rpath,/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/lib -Wl,-O1 conftest.c -pthread -Wl,--export-dynamic -L/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -lrt -lglib-2.0 >&5 In file included from ./include/orbit/util/basic_types.h:5:0, from conftest.c:45: /OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include/glib-2.0/glib/gunicode.h:23:2: error: #error 'Only <glib.h> can be included directly.' * use GNOME_MIRROR and SHRT_VER in SRC_URI Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb')
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb48
1 files changed, 44 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
index 8709cc0264..fb7e93eebd 100644
--- a/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
@@ -1,6 +1,46 @@
-require orbit2.inc
-
-PR = "r1"
-
+DESCRIPTION = "CORBA ORB"
+SECTION = "x11/gnome/libs"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+SRC_NAME = "ORBit2"
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "${GNOME_MIRROR}/${SRC_NAME}/${SHRT_VER}/${SRC_NAME}-${PV}.tar.bz2 \
+ file://configure-lossage.patch \
+ file://pkgconfig-fix.patch \
+ file://gtk-doc.m4 \
+ file://gtk-doc.make"
SRC_URI[md5sum] = "10bfb957fa4a8935a0b4afaee7d71df7"
SRC_URI[sha256sum] = "62bfce3f678f9347a19c766944e8aef7b89bc32b25ac23eb3e4c25929ce8974c"
+
+PR = "r2"
+BBCLASSEXTEND = "native"
+
+IDL_COMPILER_DEPENDS = "orbit2-native"
+IDL_COMPILER_DEPENDS_virtclass-native = " "
+DEPENDS = "libidl popt gtk-doc ${IDL_COMPILER_DEPENDS}"
+
+# IDL_COMPILER_DEPENDS_virtclass-native for some reason didn't work and orbit2-native
+# was still in orbit2-native DEPENDS causing circular dependency
+DEPENDS_virtclass-native = "libidl-native popt-native gtk-doc-native"
+PARALLEL_MAKE = ""
+
+
+FILES_${PN} += "${libdir}/orbit-2.0/*.so"
+FILES_${PN}-dev += "${libdir}/orbit-2.0/*.a ${libdir}/orbit-2.0/*.la"
+FILES_${PN}-dbg += "${libdir}/orbit-2.0/.debug"
+
+S = "${WORKDIR}/${SRC_NAME}-${PV}"
+
+LEAD_SONAME = "libORBit-2.so"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
+EXTRA_OEMAKE_virtclass-native = " "
+
+do_configure_prepend() {
+ mkdir -p m4
+ install ${WORKDIR}/gtk-doc.m4 ./m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}